Sign in with
Sign up | Sign in
Your question

Cannot change printer TCP/IP port or add new printer

Last response: in Windows XP
Share
June 3, 2009 1:37:28 AM

We've had to change our address space and therefore the printer address has changed. I've changed the address on all but one computer. On this particular computer when I try to edit the TCP/IP port I get the message:

"An error occurred during port configuration. Access is denied."

If I try to create a new port I can select that I want it to be a Standard TCP/IP Port and then it tells me:

"Specified port cannot be added. Access is denied."

Finally, I thought I would just create a new printer and create the associated port. When I try that, the entire Local Printer section is greyed out.

Next attempt was to install the printer on the DC and share it from there. This went well for the server install portion. When I select the printer after finding on the domain I get the message:

"Unable to add the printer connection. Either the printer name was typed incorrectly, or the specified printer has lost its connection to the server."

This machine has XP SP2. I've tried it with my domain admin account, my local admin account, and finally the local administrator account. The results were all the same. I've looked over Group Policy and can't see anything restrictive.

Any suggestions would be appreciated.
October 22, 2009 4:03:15 PM

I ran into the same thing recently on a machine with XP SP3. The only way I could get around it was to create new TCP/IP printer port for the printers involved. Once I did that, I could modify them as necessary and delete the old ports.
!