Password works in only Firefox browser

I have this tolerable but irritating issue when trying to reach the WebUI of my Dlink router Dir-655. In order to access the routers configuration page I must of course do so via a web browser. Once at the log-on screen I have to enter a password. Here's the rub: The password only works from Firefox. I have Chrome, Safari, IE, and Opera all installed for testing. Any of the aforementioned browsers will reach the log-on page, yet it is only Firefox that does NOT recieve an "invalid password" denial. This has been going on for several months. The machine I normally try from is a Windows 7 desktop. I've tried from a notebook I have running Ubuntu 10.4 with Chromium, Opera and Firefox... guess what.. it will also only accept the password from Firefox.

note::: I've tried copy/paste the PW and it still doesn't work. I am not mistyping it. Nor does clearing the caches work.
However, passwords to all other log-ons work within all browsers. (Except I have the same issue on my FreeNas box... sometimes)

Any Ideas?
3 answers Last reply
More about password works firefox browser
  1. give me a screenshot of the logon screen...I have a method in mind atm but need to see the logon screen first
  2. edmond419 said:
    give me a screenshot of the logon screen...I have a method in mind atm but need to see the logon screen first


    I have NO idea what showing you a screenshot of my router's log-on page would do for you... but here ya go.
  3. hm...maybe it's the way that the browser send itthe logon information, meaning that it may have a method of a security not compatible with any other browser but firefox...
Ask a new question

Read More

Internet Applications Browsers Firefox Apps