Sign in with
Sign up | Sign in
Your question

Need help with a sata raid controller

Last response: in Storage
Share
June 9, 2007 6:48:52 AM

June 8, 2007
Hi,
I am still having a problem trying to get my HighPoint (HP) 1740 pci to sata card to work. I have noticed that after POST prompts me for the HP bios utility (when my drives are connected) that it goes to a blinking cursor at the top left hand corner of my screen and just sits there. It should then display the IRQ setting of the devices on my system and other hardware information. It does not. The cursor is in the left hand corner just blinking. If everything was working correctly the hardware information would be displayed. The next thing that would appear would be the Windows XP Boot Screen. The system would then boot into Windows. But, this is not happening when I have the drives connected to the Sata controller card. It does happen when the drives are not connected and everything boots but I am missing those drives when I get into Windows.

I have also sent these emails to HighPoint asking for help. No response. Don¡¦t expect any at this point. Would not recommend any of the hardware because you can not get support when you need it.

Can anyone tell be what is happens between the time POST leaves the bios utilities and when Windows starts to boot? Is the display of all of the hardware settings triggered by software like Boot.ini, Win.ini (or one of the DOS boot files) or from firmware (like the bios I guess).

I also think that the new raid 0 array that I am trying to set up is trying to boot first when I want my mirror array to boot first. And, yes I did check my motherboard bios to set the boot priority to boot from the mirror array.
If this is your first time reading my email please start at the bottom and work your way to this latest addition of the things I have tried and the questions I have.

Thanks for your help!
Ed
June 6, 2007
Hi,
If this is your first time reading my email please start at the bottom and work your way to this latest addition of the things I have tried and the questions I have.
I tried some different connections I also had a Gigabyte GigaRAID BIOS and drivers on the system. I have removed the GigaRAID BIOS and IT8212 drivers.

With the two drives that I want to use as RAID 0 connected this is what I now see in the POST screen, all of the usual stuff, then a prompt to get into the Intel RAID (which I use as RAID 1 for my OS and other partitions that contain my applications separate from my OS and DATA), from there it goes to the rocketRAID prompt (with drives connected in all of the various views I see the RAID 0 that I set up and all is normal. I also see the two drives from which I created the RAID). When it leaves the rocketRAID utility it goes back to the POST screen and just hangs there. If I have the drives disconnected the system continues and boots into Windows.

With the drives disconnected I look at the device manager and then the SCSI and Raid Controllers. Here is what I see:
Intel 82801 gr/gh sata raid controller
RocketRaid 174x sata controller
No red X's and no ? marks.

Everything looks good and I think the way they should look with the exception that the drives are not connected.

When I look at the drives and the array in the HighPoint bios utility it appears everything is ok. But is it? Even though I see the array and the drives could there be a compatibility problem with the drives? If the drives are not compatible why can I see them in the HP bios utility? Why, then does it hang when leaving the HP bios going back to the POST and never boots to Windows? Is there a problem with the bios? It seems to me that I either have disk compatibility problem or there is a problem with the bios.
Again can you help me. This is the third email in two days and I have also called about four time leaving a message each time and have yet to receive a response.
Thanks
Ed
-------------- Forwarded Message: --------------
From: ed.sanchez@att.net
To: support@highpoint-tec.com
Subject: FW: need help with 1740 pci card
Date: Wed, 6 Jun 2007 16:25:12 +0000
Hi,
In addition to what I have sent you below I also noticed the following.
In the High Point BIOS under view it tells me that there are no "suitable devices". But other views show me the array and that everything is "normal"
When I exit the BIOS, it goes to a flashing cursor in the upper left hand corner and freezes there. Normally what happens is that DOS displays all of the interrupts and then boots into windows.
Again can you help.
Ed
-------------- Forwarded Message: --------------
From: ed.sanchez@att.net
To: support@highpoint-tec.com
Subject: need help with 1740 pci card
Date: Wed, 6 Jun 2007 06:02:49 +0000
June 5, 2007

Dear High Point Support,

I am having a problem installing one of your RocketRaid 1740 PCI cards.

My system is configured as follows:

„X Gigabyte motherboard GA8I945P Pro
„X Intel Dual Core 930 processor (3ghz)
„X Corsair memory 4 gig
„X MODEM card
„X Pinnacle video capture card
„X XFX Geforce 6600gt 128 mg pci-e video card
„X HP lightscribe DL DVD drive
„X Sony DVD drive
„X Two 128 gig Western Digital HD in a mirror array (Intel Array)
„X Two individual 500 gig HD
„X Aztec 500 watt power supply
„X Operating System is Windows XP with service pack 2

I would like to add to this configuration your 1740 pci card so that I can add two Western Digital 250 gig (WD Caviar SE WD2500JS 250 GB SATA II) drives is a raid 0 array to do my video processing.

I did get a hold of Gigabyte (before and after installing the 1740 card) and they told me that I should not have a problem with this configuration.

I purchased your card on May 15, 2007 and attempted to install it at that time. I could not. I tried calling your support line twice and could only leave a message. I never received a response. I sent you an email, and again no response.

This is what I tried today:
„X I was told that I may not have a big enough power supply, so I disconnected three of my hard drives and my Sony DVD drive.
„X I then reinstalled the card
„X Entered the HP bios and set up the array. After view the array setup, the status was normal.
„X I exited the bios.
„X It went back to the POST screen and just sat there with a blinking cursor in the upper left hand corner and would not boot into Windows.
„X I tried rebooting several times, getting in and out of the bios both the system and HP bios.
„X When I disconnected the hard drives, with the HP card in place, my system would boot. But as soon as I connected the drives and got past your bios utility,at the DOS boot screen, the cursor would blink in the upper left hand corner and go no further. It would not boot into Windows.
„X Again I would disconnect the power and the data lines to the hard drives but leave the 1740 card connected to the PCI slot and the system would boot into Windows.
„X I also updated the BIOS to Version1.1 and tried all of the above over again and got the same results.

My question is why will it not boot into Windows when the drives are connected and the HP BIOS says the status is normal? If I remember, the two 250 GB drives are on your compatibility list as compatible. What is happening.

If you can¡¦t help me I wish you would let me know. So that I can return this card to Newegg who I purchased it from. I have 7 days in which to return the card.

Thank
Ed

More about : sata raid controller

June 18, 2007 3:37:28 PM

I have an A8N32-SLI Deluxe (ASUS) nForce4 SLI motherboard and a RocketRaid 1740 card.

I have a USB keyboard.

When I have the RR card installed and three 500GB drives connected, the system won't boot and stops at pretty much the same place yours does. (stops after a message like.. "00 USB Mass storage devices detected")

soooo When I try to get into the motherboard's BIOS setup, I can. I see the seconds ticking away on the system clock. HOWEVER, when I hit some arrow keys to move the cursor around the settings.... the BIOS locks up.

This speaks of IRQ issue to me, probably. Maybe some sort of USB IRQ conflict with the RR card?

I'll try changing PCI slots (haven't done that yet)...

What I -have- tried is initializing the array with CTRL-H ... made a 3x500GB RAID-5 array. Saved RR BIOS config. Powered down system. disconnected all three sata drives from the RR card. Powered up. Boots fine into Windows. Install Windows RR drivers, then reboot, install windows GUI management util for RR card. Sata power was already connected to the HDs, so I added the sata data cable one by one to my three drives WITH THE SYSTEM ON. Worked. RR management software detected each drive after I connected it. (took 5-10 sec max for detection). Then when all three drives were connected, RAID-5 array started resynching. Took 9-10 hours total.

Now my speeds are good. Did an HDtach... 110MB/sec read speed from 0GB -> 550GB (flatlined, basically, until that point) then the read speed dropped off normally (curved downward to about 60MB/sec low on the far right side at 1000GB), avg speed over the whole disk is about 94MB/sec

BTW: the flatlining at 110MB is very very likely to be the PCI slot max speed. That's the bottleneck

Anyway I'll keep you posted on what I try. Right now I'm going to investigate firmware revisions of the card... which IRQ it's on, using a PS/2 keyboard to try to get into the motherboard BIOS with the card/drives in
etc. I'm busy at work though so don't necessarily expect a reply soon.. maybe in a few weeks :( 

It would sort of suck to have to disconnect the SATA cables from the RR card every reboot ;) 

Cheers man, and good luck with your.
June 18, 2007 3:43:19 PM

okay this is too precious.

http://www.highpoint-tech.com/PDF/RR1740/RocketRAID_174...

ROFLMAO. NOT A SINGLE nForce4 chipset motherboard is supported.

You know why I even got this RR 1740 card? ASUS sent it to me free, because I had a year+ ordeal with them showing how the nForce4 chipset's onboard RAID-5 speeds were 3-7MB/sec and there is a design defect with the SATA RAID implementation on nForce4 (and probably nForce5) Google around for benchmarks using the onboard RAID-5.... they won't be pretty :) 

(and yes, nVIDIA has actually acknowledged to ASUS (and then, to me) that this is indeed a design defect)


Sooooooo ASUS didn't even research the motherboard compatibility list before sending me a free card to make up for the total brokenness of the nForce4 RAID-5. How amusing. :) 
Related resources
June 18, 2007 4:30:53 PM

There are sometimes BIOS conflicts. To get around them, you can try pressing the "End" key when the RocketRaid BIOS loads up.
June 25, 2007 6:34:58 PM

Yep, you're the man for suggesting I try the "END" key. I had gotten it "working" previously by unplugging all the SATA drives from the controller and then it'd boot windows. I bet pressing END during the BIOS splash screen has the same effect..... not loading the BIOS.

I got a quick reply from HighPoint tech support with a more detailed answer on how I can stop the need for pressing END at every boot: Flash the HBA and in the flash utility, tell it to disable INT13 and disable EBDA Relocation. I won't be able to boot from the array in the future, but that's not a big deal.

Thanks again for the help man :) 
January 28, 2010 5:49:13 PM

I just want to say "THANK YOU SO MUCH" for the "end" key rocketraid bios bypass...

Luckily I had another drive in the machine that I can boot from... I was getting incredibly frustrated until I found this thread and it has saved my ass.

!