Sign in with
Sign up | Sign in
Your question

Netgear FVG318 router blocking (some) outgoing FTP

Last response: in Networking
Share
November 24, 2007 7:30:10 AM

I'm sorry if this has been asked before. I did a few searches but couldn't find anything related (or at least nothing which helped me solve my problem).

I've been using a Netgear FVG318 router for quite a while now, without any kind of problem. About 10 days ago however, I noticed I couldn't access one of my website's FTP service anymore (via SmartFTP on Port 21 / Passive connection). At first I thought it was a problem with my host's ftp service, so I had that verified, but everything was (and is) OK on their end.

So on went the search. It turned out I was able to connect to 1 FTP server out of half a dozain, coincidence or not: the server is located in the US. Next step I took was trying to figure out if something was perhaps wrong with my PC, so I tried connecting with my own laptop, my dad's PC and even went as far as asking a friend to bring his laptop over to give it a try. Neadless to say the result was the same (or I wouldn't be posting this).

Hooked up to my router is an Alcatel Speedtouch ethernet modem, which I've had a bit longer then the router. So I took the router out of the equation and directly connected my PC to the modem. Did the necessary changes (DSL connection requires a login and a password) and tried to connect to the aforementionned FTP servers ... and it worked. Was able to connect in a matter of milliseconds. (or seconds at least).

This lead me to believe the router might be the cause, but to rule out other possibilities I replaced the Netgear router with an old Belkin-one I still had lying around (which is not useable anymore because it hasn't got enough ethernet ports on it). Everything worked fine with that one too, no problems whatsoever logging into the ftp-servers.

Then I finally hooked up the Netgear again and .... bye bye went the FTP connection. Tried restoring a configuration backup from months ago (when everything was working just fine), tried resetting the thing (hard-reset as well as just erasing the configuration) ... but nothing seems to work.

I'm no expert when it comes down to networks so I figured I'd post my predicament and hope anyone knows what to look for or even how to fix this.

Thanks in advance ! (for caring enough to read this incredibly long and boring post :D  )
August 17, 2009 5:33:59 PM

Hi Scara1984

did you got this solved?

I've got a FVG318v2 recently... (about 4 months ago) and it was working fine... out of a sudden wireless connections started dropping and weird enough http protocol fails... I still can use MSN, ICQ, Google Talk, FTP, email and even torrents...

Been with Netgear support about 7 times now, over 3 different firmware versions (they're even send me beta ones) [ 2.1.2-67, 2.1.3-16N ] and nothing solves my problems.

More recently I noticed I started having issues with outbound FTP connections as well and I narrowed it down to the fact that apparently the router is not closing unused connections, because my hosting limits the number of simultaneous connections to 8.
One thing that I can do to kill such connections is turn on and off uPnP on the admin, but sooner than I'd like, I have to same issue....

Well... so far I'm stuck.... did you have better luck?


btw, I'm about to give up on Netgear for life.....
!