Sign in with
Sign up | Sign in
Your question

sata optical drive not detecting cd/dvds

Last response: in Storage
Share
June 9, 2007 3:21:38 PM

Hi, wondering if you guys could help me out here.

I just bought and installed an Asus DRW-1814 SATA dvd drive to replace my NEC (IDE) which i thought was broken, only to realize that the Asus was also not reading any of my dvds or cds.

I checked and updated firmware and BIOS, performed multiple reboots, checked connections and still can't find the source of the problem.

The device manager does actually detect the dvd drive and the device status is 'working properly'.

Also, when i do insert a cd/dvd, my comp experiences some lag and eventually freezes when i try opening an application.

im on an asus a8n-sli mobo and also got a sata 160GB hd connected, not sure if this will help.

Any ideas on how to solve this problem?

- Thanks
June 10, 2007 12:54:48 AM

If it's reading from 2 different drives, sounds like a software problem, assuming you tried different DVDs. What program are you using to run the DVDs/CDs?
June 10, 2007 3:05:01 AM

Hmmm...i'm not using any programs to run the DVD/CDs, should it not simply detect and autoplay?

And yes, I've tried a variety of CDs and DVDs.

Oh also, would i need some sort of a sata driver to run the optical drive?
Related resources
June 10, 2007 1:17:26 PM

No you can use either a SATA or PATA drive. You need a program to actually listen to or view the content. VLC is an excellent free video software and WinAmp is a good free audio/video software. Windows Media Player will also play both. Check this out, explains DVD decoding
http://www.microsoft.com/windowsxp/using/setup/expert/b...

Try one of the following:
1. Right click on a media file on your mp3 player and then Click Open With Windows Media Player, make sure that you uncheck the box that says to always open files of this type with WMP. If you get a message that WMP cannot open the file it means that it does not have the right Codec to read the files. If this happens, try VLC, it reads most media files. I believe, at least at one time, some players used a proprietary codec but if it's a mp3 player, then the stored files should be mp3

2. Run a media player program, e.g., WMP or VLC, Click Open, usually on the File Menu, go to the mp3 location and Clckc on the File(s) you want to play.
June 14, 2007 12:51:01 PM

Lets go back in time a bit... when did the NEC die, and did you uninstall everything with it. Check registry.

Did the NEC fail after an upgrade, or SP application? In short what were you doing when said NEC failed?

f61
June 14, 2007 2:57:28 PM

The NEC failed when i attempted to burn a cd. So I assumed it just died from overuse so i bought the Asus.

I don't think i even used any firmware for the NEC, only software i installed with it was the nero bundle and that was about it. As for the registry, how would i go about to check?
a b G Storage
June 14, 2007 3:57:55 PM

Try reflashing the optical drive.
June 14, 2007 4:40:39 PM

Quote:
The NEC failed when i attempted to burn a cd. So I assumed it just died from overuse so i bought the Asus.

I don't think i even used any firmware for the NEC, only software i installed with it was the nero bundle and that was about it. As for the registry, how would i go about to check?


Firmware is actually software that is part of the drive itself. Go to the ASUS web site and find the firmware for your particular drive and there should be directions for flashing. Be sure you have the firm ware for your particular drive and follow the flashing directions exactly
June 14, 2007 5:42:28 PM

Quick quesiton first - if you boot up with a disc in the drive that has some data on it, can you access it?

One of my current xp installs does not recognize disc changes which in turn causes almost all burning software to fail...unless I boot up with nothing or a blanc in the drive.

Also, can you access the drive from safe mode?

To have two drives not working on different connection types sounds more like a windoze problem as opposed to a hardware one....

obi
June 14, 2007 5:51:33 PM

I've seen this happen on XP-64 after a Windows DRM update.
What OS are you using, have you down-loaded any updates recently?
June 14, 2007 6:29:51 PM

I am having a very similar problem with my HP DVD740i (PATA/IDE interface). Device mgr claims the device is working fine. But I cannot boot a Windows XP install CD on the drive, and when I try to use the drive for watching a movie or whatever, I get a message such as Media Not Present. It's as if the drive doesn't detect the disk, or there's a wire to the Mobo that isn't getting the media present signal across.

Mobo is an Intel D955XBK, O/S is Win MCE 2K5, with all critical MSFT updates to about a month ago. But since I can't even boot the MCE 2K5 install CD, I don't think it's a software problem.

The problem started some time this year (sorry - I don't use the drive all that often).

If I can, I will try the drive in a different computer, and try a different drive in this one, to narrow down the search for the problem. It's just a pain to disassemble the computer to the point I can remove the drive.
June 15, 2007 12:38:11 PM

Gent: you may be onto something. This does smack of a DRM DoS to the optical drive. And it won't be limited to X64 either. That would put the problem well outta my league. Be careful of your updates, if it doesn't apply to you, DON'T load them!

Other than that, go into bios and check the BOOT SEQUENCE and set it to optical drive as first choice (if ATAPI select CD-ROM... if SATA check BOOT FROM SATA or OPTICAL DRIVE or CD-ROM) Make sure the floppy or the usb is NOT first boot. I believe the DEFAULT setting is still Floppy first, sometimes upgrades or SP releases to M$ Windows (especially SECURITY types) will cause this the BOOT SEQUENCE TO RESET TO DEFAULT (Floppy first).

HtH
f61
June 15, 2007 3:03:08 PM

@g-paw: I've already tried reflashing but still no results.

@obiwan05: I've tried booting up the drive with a disc inside but all i end up with is a blank screen after the windows loading screen.

I've also tried safe mode, still the same thing, cd/dvds aren't detected.

@Gent: I'm running on 32-bit xp although i've got an amd athlon64 cpu.

@f61: I've tried changing the book sequence as i realized that floppy was indeed #1. But cd/dvds still weren't detected :( 


This might help you guys...when i insert a DVD, i can hear the drive spinning but the drive doesn't detect it and after a moment it comes to a halt. As for a CD, it does not spin at all.

Also, would you guys advise that i try a reformat to rule out any software problems? (although i'd like to see this as a last resort)

Overwhelmed by all the responses, thanks guys, keep trying!
June 15, 2007 3:48:32 PM

Try booting from a bootable CD/DVD first, if it boots OK then it's a Windows/software issue, if it doesn't boot then it's probably hardware.
June 15, 2007 4:46:16 PM

I think it might be NERO.
Uninstall NERO completely, find its left-over folder and shread it, use Regedit and delete the NERO keys.

shut-down, turn-off.

open case (Ground yourself and the case) and make sure the SATA cable for the HDD is on header #1, and the SATA cable for the OPTICAL is on #2. If not, fixit.

EDIT===> I forgot one thing... make sure there is power for each device, and double-check both power connectors. A bad connection/wire can't be ruled out yet.

Close case, un-ground, and power-up.

restart, let windows detect the drives, and reload NERO.

Maybe windows/NERO collision or conflict. One reads IDE as the optical, the other as SATA.

Any thoughts before trying this?

f61
a b G Storage
June 15, 2007 6:44:51 PM

Delete the drive in device manager and restart the computer. Let Windows redetect the drive.
If you have a spare drive, try it in this computer so we can rule out the controller.

If all this doesn't work, RMA the drive or buy a new one.
June 16, 2007 2:47:13 AM

Thanks pjbywor, that did it. Installed the latest nforce 4 drivers and everything works perfectly now!
June 16, 2007 5:55:41 AM

No worries, the problem had me going round in circles for a while cursing both Samsung and Asus

Paul
June 22, 2007 2:49:00 PM

Thanks for the guidance. I had a very similar problem to the original poster. I tried booting from my XP MCE CD, and the computer ignored that and booted from the hard drive. I then plugged in a spare CD player and put the XP MCE CD in that, and the computer booted from that just fine. So either it's (almost definitely) a hardware problem, or maybe it's some kind of rootkit I haven't heard of.

Question: Is there any possibility that there is some rootkit that would "filter" one of the drives but not the other?

I'll try the errant drive on another computer and see what happens. I know it's not a FW problem because the latest is installed. Either way, I'm off to buy a replacement DVD drive.
June 26, 2007 2:58:26 AM

If one thinks its a rootkit, just boot using the original floppy/CD.

Personally I don't think its a rootkit. And there is a post under the "general" topics of this section that deals with this problem. The answer is either reload the nvidia/ati drivers or delete the drive as you did. This is a known issue with Xp and Vista. BTW: The error codes may also include 19 or 39.

f61
!