Sign in with
Sign up | Sign in
Your question

SQL Slowness

Last response: in Applications
Share
September 22, 2010 3:58:29 AM

I'm dealing with a piece of software called Client Profiles. It's an MSSQL database-driven case management application for law firms. The database runs fine locally, but not remotely. I've tried ruling out as much as possible, but I've hit the end of my road. Here's the backstory:

The main site uses a Linksys RV042 router. It's used this router for quite some time. The remote site was using a WRV210. Unfortunately the WRV210 would drop the VPN at least once a week. Since the database, files, and phone server (VOIP) are all at the main office, every time the vpn went down the remote office was completely down.

Last week we replaced the WRV210 with an RV042 at the remote site. They can live without the wireless for now. I didn't make any changes to the VPN at the main office and just set up the new router to match. The VPN came up without a hitch.

The internet runs fine at both sites (8x1 connections at both sites). The phones use the G711 codec and so each call at the remote site takes up 100K each way over the VPN. They have often had 4-5 calls at a time without issue so traffic flows properly. I can navigate to the server at the main site from the remote site and download a file at 600-700K without an issue. Again, the VPN and internet seem fine.

However, once we upgraded from the WRV210 to the RV042, Client Profiles (SQL driven database) runs extremely slow. Looking online for a resolution constantly has people pointing to the upload speed of the internet connections as the bottleneck. I'm positive that is not the case here. It worked fine on the old router and should be working fine on this router. Also, as I watch network traffic, it see very little movement (10-20K), then a momentary spike to around 300K, and then very little traffic again. Before the router change CP would load in under 5 seconds. Now it's taking about 1 minute.

I've even tried port forwarding through the router and bypassing the VPN all together, but it doesn't seem to be running any faster. I've tried switching from TCP/IP to named pipes and back. No change. I've tried manually setting the MTU to 1500 and still no change.

Even now at near midnight I can push a file from the main site to the remote site at over 700K. I can push a file from the remote site to the main site at consistently slightly better speeds. But when CP tries to communicate I very little, then a blip of about 300K, then very little and it takes forever to load and navigate.

Any help would be GREATLY appreciated!

Thanks

More about : sql slowness

September 22, 2010 5:16:03 PM

As a test, disable firewall on the PCs and turn of anti-virus scanning. If the Router has a firewall, disable that if you can.
m
0
l
September 22, 2010 6:30:17 PM

Firewalls are already disabled on the server and PCs. I can't disable the firewall on the server's router due to port forwarding. I'm pretty sure that the packets coming through the VPN aren't scanned by the firewall anyway since they are considered local. I'll disable AVG on the server and see if that helps.
m
0
l
Related resources
September 22, 2010 6:33:46 PM

It almost seems to me like there is some packet checking for viruses or maybe error checking going on before the data is sent out. I have seen similar issues happen to email, but I guess that is not quite the same thing.
m
0
l
September 22, 2010 8:19:15 PM

I disabled AVG and it's still painfully slow. So no firewalls or AV.
m
0
l
September 27, 2010 2:13:47 PM

We adjusted the encryption level of the VPN and things are much quicker now. Wonder why... Router too slow?
m
0
l
September 27, 2010 2:49:27 PM

Encryption does eat up a lot of processing if the hardware is not made for it.
For example in a PC, encryption will drop a drive access time by a huge amount unless you have chip-level decryption available.

Could be the model of the Router, but I don't deal with them that much to offer you any suggestions for a model to try.
m
0
l
!