Sign in with
Sign up | Sign in
Your question

Problems setting up RAID 0 on p35 abit

Last response: in Systems
Share
June 10, 2007 4:42:12 PM

Hi everyone

Ok so I just got a newer build. My old system had been with me for 3+ years and it was time to get something else.

I got the abit IP35 Pro and I am liking it very much. With the exception of one thing. I was unable to set up a RAID 0 to install windows into. I have used raid0 and I am a bit of a fan of it.

I have set up raid 0 machines in the past so I am not exactly new at it.

This is what's happening now.

In the bios I changed the sata controller to raid. Then in the post screen I build a raid 0 array with my 2 hard drives. Thereafter I reboot with the Windows cd in the drive. Upon entering the windows installation I hit F6 to add addition drivers. (This motherboard's CD does come with the option of building a driver disk for the new ICH9R chip). After asked to add additional devices by pressing S I think I put the floppy in and I am asked to select the type. I chose the Intel raid something or other 32bit because I am installed 32bit XP. At this time the system reads the floppy and everything is fine. Then it asks for additional devices. I say no. (All of this is the same as with all other machines I have played with so far) At this point the installation continues as normal. I am then given the choice of wher to install windows. My raid) array is the only option as that's all I have. I choose it and format it no problems there. Thereafter files start to be copied into the HDs and about half way through that process the System comes up with an error saying something like "unable to copy iastor.ini" or .inf or something anyway this is the same file I originally copied over after pressing F6. Now, no matter what I can't get past that error. I have tried multiple floppys with no luck. if I skip it then installation will crash once windows attempts to boot.

Not sure what the problem is or if anyone has a work around. Any input would be appreciated.

Thanks.
a b B Homebuilt system
June 10, 2007 5:19:30 PM

Does your board have multiple RAID capable chipsets, if so are you sure you are selecting the correct driver for the one you are using?
June 11, 2007 1:38:07 PM

Yes the board does have 2 chips. one is the intel and the other is a Jmicron which (according to the manual) controls the eSATA but not any of the interntal SATA connections. additionally the problem really show up when copying the files over as mentioned in my original post. I just haven't the slighest idea as to what could couse that to happen.

Any help would be appreciated.

Thanks.
Related resources
June 11, 2007 2:26:49 PM

problems with an ABIT? Strange :?
Once you hit F6 upon installing os xp, at the end of all the loading it should ask you to insert disk and press enter, after that you press s to install the necessary drivers for the chipset, so that you mobo will recognize the raid 0 settings. you need to install the update and then after that press s again to install the second driver, if you see the inside of the floppy, there should be to files that say, install <recommended> those are the to that you will want to install.
GL :wink:

Keep on posting
June 11, 2007 8:15:10 PM

First, I'd never recommend using any motherboard-based RAID setup. It has all of the downsides of being tied to a specific piece of hardware like hardware RAID controllers but none of the benefits like XOR/checksumming offload. RAID 0 doesn't do checksumming or XOR (that's used in RAIDs 3, 4, 5 and 6) but the SATA ports on most motherboards can't handle the amount of data that several disks in an array can pull through them. I've not used the ICH9/ICH9R chipset, but the NForce 3, 4, 500 and 600, ATi SB480 and SB600 as well as all of the SATA-capable Intel southbridges (ICH5/6/7/8) suck at running more than a couple of disks in an array and some suck at running even two. There seems to be a bottleneck of about 100 MB/sec aggregate data passing through all SATA ports at any one time in most chipsets. You'll never see that if you have only one HDD or non-arrayed HDDs but once you have them in an array all pulling data through at the same time, it becomes painfully apparent. That is why I always use PCI-X or PCIe SATA or SCSI RAID cards. Those use the full bandwidth of the PCI-X or PCIe bus and don't bottleneck nearly as quickly as the integrated ports do.

Secondly, don't put your user files on a RAID 0. That's just asking for trouble. The OS is one thing as it's reinstallable, but you can't get back your files if they're on a RAID 0 that has a disk die. That's why my files are on a RAID 5 where one disk can die and nothing happens. And they are BACKED UP DAILY.
June 12, 2007 2:25:19 AM

Thanks for the advice MU_Engineer . I do have an additional drive which has been with me for a while and has been very reliable. I do prefer a single 2 disk RAID0 just for loading of big files is all. I have used it in the past and have liked the results. Problem is I can't figure out why this is not working for me. I am thinking there is an issue with my floppy and or floppy cable because everything else seems to be just fine. I don't know why it load the file the first time tho after pressing F6 during installation and then fail to load all the remaining files in the "installation files are now being copied" phase. Thats just beyong me. I will try it again this weekend and we'll see I guess.

Anyone else have any suggestions as to what the problem might be? or has this happened to anyone else in the past? I suppose the floppy itself could be bad so I will try several different (new) ones this weekend.
June 12, 2007 4:44:59 AM

I just did this twice with the P35 chipset.

Both times, it read the drivers from the floppy when I first select the drivers but later, after it finishes formatting the hard disk it wants to read the files off the floppy again.
So be sure to leave the floppy in the drive until it finishes the "copying files" part.

I'm on a Gigabyte P35-DQ6 which also has another SATA/PATA interface.
I installed drivers for both at install time.

I noticed that if I started windows install with the floppy disk in the drive, it wouldn't recognize when I changed disks to install the additional driver.
If I left the disk out until the installer told me that it could not find any mass storage devices, then I could insert either disk and select both drivers.

Try leaving the floppy out of the drive and don't press F6 at the start.
Wait for the installer to tell you it couldn't find any storage devices, then it gives you the option to press S to install drivers.
If you have multiple sata controller, install drivers for both.

That's what worked for me anyway.
June 12, 2007 1:27:36 PM

Thank cahutch, it seems that you had a similar, if not the same issue with the installation of windows as I am having now. It recognizes it first and then after the copying fiels part gets started it will look for them again and will not recognize the floppy. When i tried it again I noticed that it wouldn't even attempt to read the floppy drive at all.

Now I didn't know that if you didn't press F6 that the installer would then ask to install drivers after it was unable to find any storage device. That may be the workaround i am looking for. I will hopefully try this it tomorrow night (as I am out of town tonight) and I'll post what happens.

I am relieved to know that similar issues have occured in the past and this may not be an isolated problem to my board.
June 14, 2007 1:39:15 PM

So umm that didn't work.

I am wondering if anyone out there has this board and has been able to succesfully install a fresh copy of windows XP onto a raid0 partition. ?
June 14, 2007 10:50:33 PM

Do you have a new dvd/cd drive or are you using your 3 year old drive ? If your floppy isn't getting the full info eg. a missing or unreadable file then £20 for a new drive could sort this out .I had something similar and this was the answer ????
October 28, 2007 11:38:25 AM

Hi guys, I am having the exact same problem with an ip-35, if you have found a solution, please post it as I am completely baffled!!!
January 15, 2008 12:25:29 AM

I had very similar problem a finally got it working.

I orginally had it configured with an pioneer ide dvd reader set to master, ide hard drive set to slave, serial drive on port 1.

not sure if this board with handle ide and serial drives mixed like this.

I got the system working by replacing the ide dvd drive with a new memorex dvd burner, the cable, removed the ide hard drive, formated the serial drive with another computer, and reset the cmos.

I was installing a vista premium 64 upgrade so I had to install xp first. I created the f6 disk with the abit utiility and installed xp with the bias set to raid, everything went well. When I did the upgrade to vista, and had to load the raid drivers, none of the raid drivers on the f 6 disk matched the ich9 chipset. I had to load the raid drivers from the motherboard cd rom? the os was looking for the ich9

I installed the intel raid matrix manager in windows everything looks normal.

March 30, 2009 6:50:35 AM

I too am having this problem installing Raid 0 on my ip35 pro. Exact same process and error as Nameless7. It says that it is unable to copy "iastor.sys" from the floppy. Skipping that file, it can't copy iastor.inf, iahhci.cat, etc. What is causing this?! I doubt anything to do with the floppy. I am wondering if the driver can be slipstreamed onto windows XP using nlite, but I am not sure how to "ask" XP to use drivers on the CD itself. It's late, will try this tomorrow... maybe. :sol: 
!