Sign in with
Sign up | Sign in
Your question
Closed

Spell Check Does Not Work (Word 2007)

Last response: in Applications
Share
September 23, 2010 3:15:43 PM

Hey all, I hope you can help me with this one because it's doing my head in.

I have a Windows XP machine running Microsoft Office 2007, and for some reason the spell check feature has suddenly stopped working; no matter what garbage you type, it will not underline it with the usual red squiggly line. I have tried a few things but have not managed to fix it yet, so I feel I am out of options.

I've tried making sure UK English is the default editing language in Word and that "do not check spelling or grammar" is unticked; I've deleted 'Word' registry key from HKEY_CURRENT_USER > Software > Microsoft > Office > 12.0 > Word but with no luck. I've tried making sure HKEY_CURRENT_USER > Software > Microsoft > Shared Tools >Proofing Tools key is setting correctly, too, but nothing. I even used the Word Diagnostics tool, but that (as I expected) found nothing.

I hope you guys can help!
Anonymous
September 23, 2010 10:03:51 PM

i've got same issue all of a sudden -- think there is a virus causing this?
September 24, 2010 9:00:06 AM

give this a try :

1) First you need to open a Microsoft Word document
2) Click the MOB (Microsoft Office Button) at the top left corner
3) At the bottom of that menu is a button labeled "Word Options" (it's next to "Exit Word")
4) On the left side is a list. Click "Add-Ins"
5) At the bottom of this menu there is a small box next to the word Manage
6) Click that box and select "Disabled Items" from the list
7) Once you have selected this click the "Go" next to it
8) A new window will open and if on of the options has the words "Spell Check" then select this
9) Once the option is selected then proceed with clicking Enable.
10) Close the "Word Options" menu and proceed to type an obvious misspelled word to test it.
Related resources
October 6, 2011 4:28:28 PM

I have MS word 2007 running on a Windows 7 computer, and it's not even marking "gsdjkg" as misspelled. :o  What. The. Hell.
February 22, 2013 2:39:52 PM

1st reply to Mr cbviking.
Enable option is already disable.


2nd
unticked; I've deleted 'Word' registry key from HKEY_CURRENT_USER > Software > Microsoft > Office > 12.0 > Word but with no luck.
But No luck ? mean ?
April 26, 2013 7:32:57 AM

cbviking said:
give this a try :

1) First you need to open a Microsoft Word document
2) Click the MOB (Microsoft Office Button) at the top left corner
3) At the bottom of that menu is a button labeled "Word Options" (it's next to "Exit Word")
4) On the left side is a list. Click "Add-Ins"
5) At the bottom of this menu there is a small box next to the word Manage
6) Click that box and select "Disabled Items" from the list
7) Once you have selected this click the "Go" next to it
8) A new window will open and if on of the options has the words "Spell Check" then select this
9) Once the option is selected then proceed with clicking Enable.
10) Close the "Word Options" menu and proceed to type an obvious misspelled word to test it.


April 26, 2013 7:34:07 AM

Well done. I did exactly as per your instructions and now it is working. Thank you.
July 7, 2013 11:21:08 AM

cbviking said:
give this a try :

1) First you need to open a Microsoft Word document
2) Click the MOB (Microsoft Office Button) at the top left corner
3) At the bottom of that menu is a button labeled "Word Options" (it's next to "Exit Word")
4) On the left side is a list. Click "Add-Ins"
5) At the bottom of this menu there is a small box next to the word Manage
6) Click that box and select "Disabled Items" from the list
7) Once you have selected this click the "Go" next to it
8) A new window will open and if on of the options has the words "Spell Check" then select this
9) Once the option is selected then proceed with clicking Enable.
10) Close the "Word Options" menu and proceed to type an obvious misspelled word to test it.


July 17, 2013 4:52:26 PM

This works for me too. It seems that the setting is disabled for some reason.
September 4, 2013 2:03:47 PM

cbviking said:
give this a try :

1) First you need to open a Microsoft Word document
2) Click the MOB (Microsoft Office Button) at the top left corner
3) At the bottom of that menu is a button labeled "Word Options" (it's next to "Exit Word")
4) On the left side is a list. Click "Add-Ins"
5) At the bottom of this menu there is a small box next to the word Manage
6) Click that box and select "Disabled Items" from the list
7) Once you have selected this click the "Go" next to it
8) A new window will open and if on of the options has the words "Spell Check" then select this
9) Once the option is selected then proceed with clicking Enable.
10) Close the "Word Options" menu and proceed to type an obvious misspelled word to test it.


September 4, 2013 2:06:00 PM

cbviking - you are a superstar. I've been pulling my hair out trying to get my spell check to work and I've been trying every solution under the sun. Your's worked first time. Go global and make a name for yourself by posting this solution. It is the absolute best by far. 3 cheers to CBVIKING.
September 25, 2013 6:53:07 AM

cbviking said:
give this a try :

1) First you need to open a Microsoft Word document
2) Click the MOB (Microsoft Office Button) at the top left corner
3) At the bottom of that menu is a button labeled "Word Options" (it's next to "Exit Word")
4) On the left side is a list. Click "Add-Ins"
5) At the bottom of this menu there is a small box next to the word Manage
6) Click that box and select "Disabled Items" from the list
7) Once you have selected this click the "Go" next to it
8) A new window will open and if on of the options has the words "Spell Check" then select this
9) Once the option is selected then proceed with clicking Enable.
10) Close the "Word Options" menu and proceed to type an obvious misspelled word to test it.


well then waht if SPell check does not apear in the window?
December 9, 2013 12:16:34 AM

To resolve this problem, complete the methods that are provided in this article in the order in which they are presented. If you have previously tried one of these methods, and it did not help to resolve the problem, you can skip that method and proceed to the next one.
To install the proofing tools, follow these steps:
Exit all programs.
Click Start, and then click Control Panel.
Follow the appropriate step for your operating system:
In Windows 7, click Uninstall a program under Programs.
In Windows Vista, double-click Programs and Features.
In earlier versions of Windows, double-click Add or Remove Programs.
Click Microsoft Office Edition, and then click Change.

In the Microsoft Office Edition dialog box, click Add or Remove Features, and then click Continue.
Expand Office Shared Features, click the icon to the left of Proofing Tools, and then click Run all from My Computer.
then continue.. problem solved..
December 17, 2013 7:18:08 AM

I have tried everything on this page and still no success. If I open a new document and type a misspelled word then it underlines it. But then as soon as I copy and paste the text from a document where the spell checker is not working into the new document it doesn't detect the spelling errors in the copy and pasted text
December 27, 2013 12:09:05 AM

It can't find it in pasted text - only text which was typed live. Time to close this old thread now.
!