Sign in with
Sign up | Sign in
Your question

How to disable access to FAT drive / Start Menu for Guest

Last response: in Windows XP
Share
August 18, 2009 11:35:37 AM

I allow my children to use guest account to play games etc. on the PC and allow them minimum permissions.

I need to allow them access to only limited programs and drives so that they do not inadvertantly change/delete other files. For this, I have restricted them access to the NTFS drives using DENY permission for the guest account.

However, I use MagicJack for phone (It is a USB device with one end going into USB slot and other has phone jack to which a normal phone can be connected). The problem is that MagicJack software has to be running and for this, first I log into administrator account from where the software runs and the phone software comes up on screen. Once it says Ready to Call, I "log off" using switch user. This leaves the software running and the phone working. The USB device has to be plugged into the machine all the time as in essence it is a phone connection.

My problem is this. MagicJack installs two (very small sized) USB drives into the system, one CD and one removable disk of few MB for contact list etc. However, both these drives are FAT / FAT32 drives. Hence, I cannot set permissions on these to DENY for guest users (and even if I do, they do not work).

I want my children NOT to touch these drives as that can cause problems with the device's normal functioning. How do I do this ?

In summary, I want to DENY access to GUEST account ability to access FAT/FAT32/CD drives as also HIDE the taskbar (including the start menu) from guest account only.

I tried TweakUI, Tweak-XP Pro but they hide the start menu / drives for all users. Still the drives are accessible if I type the drive letter in explorer even though they do not show up in the list.
August 29, 2009 3:29:35 PM

If your using XP pro then try:
Start > Run > type in "gpedit.msc" (no quotes)

it has loads of setting in there, there might be something in there. you'll need administrator to edit it.
m
0
l
!