Sign in with
Sign up | Sign in
Your question
Solved

Why is Vista slow on my laptop?

Last response: in Windows Vista
Share
December 24, 2009 6:54:35 AM

I have a Dell Inspiron with an AMD Turion TK-55, 2GB RAM, and ATI x1150 integrated graphics. It came with Windows Vista Home Premium and it's slow as hell. The computer is only 2 years old. I've gotten rid of all the aero graphics I'm using classic windows, I check my system for malware weekly, I clean my registry weekly, I update daily, and I delete unnecessary files. Despite all this vista is still using 50% of my memory and running very slowly, start up alone takes 5 minutes. Why is this happening why is it so slow, if this were XP it would be extremely fast, I ran Ubuntu on it for a day and it was twice as fast (but Ubuntu is a little complicated for me). So why is it so slow?

Oh and also on a second note I'm removing my anti virus system from my Dell laptop so do I still need an anti virus or is Vista secure without one?

More about : vista slow laptop

December 24, 2009 12:12:54 PM

First, 2GB of ram for Vista is decent, but the performance won't be anything to write home about. Either add more ram, or move to Windows 7.

Second, your computer (regardless of the OS used) is only as secure as the person sitting in front of it. If you aren't a complete idiot about what you do (more specifically, what you download or install) on the system, you should be ok.
m
0
l
December 24, 2009 12:56:22 PM

Try to disable unused programs from start-ups.

Click on Windows Icon, type msconfig into the search box

Select Startup from the top tabs

All these programs that you see, unless un-ticked they will load when windows starts up. So go through them, see which one is not required to loadup and then un-tick it. The essential programs that should load up are Java (from Sun Microsystem), Anti-Virus programs, and backup program.
Now click Apply and OK. Restart your system. Windows should start faster.

If windows was still loading slow (“5 minutes”), then run msconfig again. This time select the services tab, most likely one [or more] of these programs is causing the delay. So go through them and uptick the third-party programs. (don’t touch any programs which under Manufacturer Microsoft, Intel, AMD, Nivida, ATI corporations and also your AntiVirus/backup program).
……………………………………………………………………………………………
If windows was starting faster, but a particular program that you use was not functioning properly, then under service Enable it again.

……………………………………………………………………………………………
Also run Disk Defragmenter


m
0
l
Related resources
December 24, 2009 3:48:00 PM

OK I've already disabled most of the unnecessary start up programs a long time ago and it didn't help a whole lot I've still got the same old 5 minute start up.
m
0
l

Best solution

December 24, 2009 7:08:19 PM

That's a good link from Scotteq....

It could be some buggy drivers, corrupted windows, or hardware malfunctions that’s causing the delay.

I suggest you run windows Diagnostic mode, and see if it still taking 5 minutes to load.

Run the msconfig again, and under General tab choose Diagnostic Startup. Click Ok. Restart.

Still the same?





Share
!