Sign in with
Sign up | Sign in
Your question

D link dwl g730ap in Client mode

Last response: in Wireless Networking
Share
June 2, 2008 5:30:09 AM

I am having fits trying to get my link dwl 730 to work in Client mode. I have no problem at all using it as a router and it is a great little travel router. I am supposed to be able to get it to work in Client mode and I just can't get the computer to recognize it. I have it set to a WAN of 192.168.1.30 as opposed to 192.168.0.30 from the factory. If I log on to my Verizon Fios's actiontech modem I can see it at a LAN of 192.168.1.11 so it is doing something. My windows XP laptop keeps giving a message that there is limited or no connectivity, and when I try and connect to it via that machine and a browser I keep getting page not found errors. If I switch it back to router mode, I can connect no problem and get to the browsers pages, but it looks like I have to be able to do it in client mode. I'd like to get this thing working and then ultimately use it to allow my tivo HD to access my network.

Can anybody think of any settings I need to look at or may be missing? I appreciate any help, thanks in advance!
August 24, 2008 5:25:31 PM

a767pilot said:
I am having fits trying to get my link dwl 730 to work in Client mode. I have no problem at all using it as a router and it is a great little travel router. I am supposed to be able to get it to work in Client mode and I just can't get the computer to recognize it. I have it set to a WAN of 192.168.1.30 as opposed to 192.168.0.30 from the factory. If I log on to my Verizon Fios's actiontech modem I can see it at a LAN of 192.168.1.11 so it is doing something. My windows XP laptop keeps giving a message that there is limited or no connectivity, and when I try and connect to it via that machine and a browser I keep getting page not found errors. If I switch it back to router mode, I can connect no problem and get to the browsers pages, but it looks like I have to be able to do it in client mode. I'd like to get this thing working and then ultimately use it to allow my tivo HD to access my network.

Can anybody think of any settings I need to look at or may be missing? I appreciate any help, thanks in advance!



I'm having the same problem - did you happen to find a solution? I'll let you know if I do.
August 24, 2008 9:56:39 PM

Ok, I have it working. I'm not sure I was doing anything wrong, but I do understand how it works now and will describe it here.

First of all, as in the documentation, the default address of the device to manage it is 192.168.0.30. I was able to manage it on this address after performing a reset by powering down while holding down the reset button. I expect there is a slightly different method to just do a reset, as when I first hit the management page after that, it was in simple mode, asking for a firmware update file. I rebooted it again, and it had obtained factory defaults when I hit the management page.

I went to the wireless section and put in my wireless network's ssid and WEP key. I did a site survey, it found my network and I selected and connected to it. There doesn't seem to be anything on the status page to indicate that it's actually connected. It shows the information you've entered, but if you enter it wrong I'm not sure it would appear any differently.

On the LAN page, change the address of the device if you desire. Fill the the gateway of your wireless network, likely your access point IP, and enter it as the DNS server. This is likely what you missed doing if you were actually able to access the management page.

If all has gone well, you now need to set your network connection to DHCP - the DWL-G730AP will act as a bridge device. You will get a DHCP issued address from your regular wireless access point, and all other settings.

I really fault D-Link for not spelling this out more clearly. They don't identify the step of using a static address then going back to DHCP, and don't identify it as a bridged configuration. Granted, not all buyers are at a level to understand or care about this, but to those used to working in several different modes, this is important information. I am suspicious that there are a lot of people who are not able to use the existing instructions to utilize it in Client mode.

Good luck, I hope you're able to get it going.
Kevin
Related resources
October 7, 2008 4:18:54 PM

Hey Everyone,
Just a question here. Is it required to have a dedicated wireless AP set into bridge mode to communicate with the DWL-G730?

I have an existing AP in my home that I want to connect to, using this DWL-G730. I already use my existing Netgear AP for connecting to our
Laptops and other equipment. I purchased the DWL-G730, thinking that I could set it into Client mode and it would connect to my Netgear AP
just like another PC. I have done AP bridging before where you dedicate each AP to talk to each other. But when you set it up for dedicated
bridging, it is unable to do anything else.

Is this how to use Client mode with this DWL-G730


Thanks for your time,
January 7, 2009 2:23:10 PM

Thank you to kgouldsk for pointing out that the DWL-G730AP is basically a bridge when in client mode. I spent some time today trying to get this to work as well, and there is one more detail I think is important to point out:

If you are using MAC address reservations for your clients in your wireless AP, then you need to add the _wired_ MAC address of the client computer you have the G730 connected to - NOT the MAC address of the G730 itself.

It took me a while to figure this out, and I did it by temporarily disabled the client access list and seeing who showed up.

Hope that helps others.

Tyler
Anonymous
January 24, 2009 7:35:16 PM

I have the similar problem that I am unable to use client mode, but I cannot use any mode, because I cannot access the configuration site (192.168.0.30) at all. I have tried resetting it andhave tried using it on 2 different computers. I need to configure it because I bought it to use for my Xbox 360 and for a travel access point.
April 26, 2009 10:47:34 AM

You will need static address on PC such as 192.168.0.100 to access the device at 192.168.0.30 - once you have access, set wireless up, then change client LAN to dynamic, ... then change your PC back to dynamic IP addressing; then restart both/all ... both the 730AP and your PC will then get IP addresses from your wireless router (which must have DHCP enabled); I use client mode into Belkin 7633 and all works fine. (PC static address to start with is the trick)... the other modes provide DHCP from what I recall.
May 14, 2009 2:56:24 PM

I got the unit to detect the wireless connection and I am able to connect using the Client mode.

Question
Since I had to set my computer as an static ip such as 192.168.0.100 to inorder to connect to my dlink using 192.168.0.30, after i added the wireless access point I then changed the LAN to dynamic and did the same for my pc.

How do I get back into my Dlink client router, 192.168.0.30 no longer works which is normal as it is set to DHCP.

Example if the address that is giving me is now 192.168.1.30, and i type in 192.168.1.1 it gives me my netgear router login page rather then my Dlink client router. How do you get back into your dlink when it is set to DHCP without needing to reset your Dlink everytime to add a wireless connection.

Please advise
Thanks
May 5, 2010 1:20:09 AM

The key here is to NEVER set the DWL-G730AP to DHCP. Once that's done, it is bitter to get it reset to factory. I tried many times of holding reset, unplugging power, plugging in power, let go of reset, unplug, replug. Finally I got it back. Now I have my wireless settings in and can get back by using manual i/p on the computer and the base address (192.168.1.30) to change settings. (Alternatively you could set the G730AP to an address in your normal DHCP range so you don't need to go elsewhere, just don't set it to DHCP.) Just set your computer to DHCP when finished, not the G730AP.
Anonymous
August 25, 2010 3:23:43 AM

I thought I would add some info about the DWL-G730AP that I did not see posted here already. When using the device in client AP mode it is important to not that it will not connect up to a wireless router that is using WAP-PSK or PSK2 that is in AES security mode. It will only connect to a WAP-PSK router in TKIP mode.
September 11, 2010 12:35:38 PM

I am having the same problem as the original poster and cannot get the DWL 730Ap to work in client mode even after trying a reset while powering down.

Grateful for any help, but in simple language please.
February 13, 2012 3:54:58 AM

I know this might be old news, but it's still relevant. 7of9sdad is spot on except for one thing. You do not need to set the lan to dynamic. You actually want to leave it static so you can get back to the page easier. One of the tricks is that if your router is 192.168.1.1 then you make the static ip something like 192.168.1.200 that way after you are done and you have to change your wireless connection you will easily be able to go to 192.168.1.200 and access your client mode settings. After you are setup you can change your computer back to obtaining it's ip address dynamically. Thanks 7of9sdad for that hint! It's all about making sure your computer has a ip address of something like 192.168.0.100 so you can access the client mode settings. After you setup correctly then you don't have to worry about that any more. For some reason this unit doesn't seem to like to give your computer an IP address when it's set to 192.168.0.30 I found that extremely annoying.

Anonymous is absolutely wrong since I have mine connected perfectly with AES. You just need to make sure that you have the latest 200 firmware.

You don't need to mess with DHCP either.

Once in go to the LAN button and setup the information to match your router.

Leave Static IP selected
If your router's ip address is 192.168.1.1 then for the ip address put 192.168.1.200 or whatever you have available
Most won't have to change the subnet mask
Gateway and DNS should be set to your router's ip address 192.168.1.1

After that if you are in a remote location just remember this unit talks to a router in client mode and if the router you are connecting to has a different ip address you will probably have to change the static ip address to match that router. That would be the reason to set it to dynamic if you travel a lot, it will just make it more difficult to change things as you will have to either figure out it's new address or reset it. So it's easier to just leave it static and change it to match the router wherever you are IE. (Hotel). The managers can usually provide you the details to connect.
!