Sign in with
Sign up | Sign in
Your question

X850 XT PE, overheat problem GPU. Need Help Please!

Last response: in Graphics & Displays
Share
June 15, 2007 11:52:06 PM

Hello,
I bought my computer 2 yrs ago. I have a Dell XPSGEN5. Its been good. no problem at all. about 1 weeks ago. it auto shut down when I start playing BF2 for couple mins.
Comp specs:
Win XP
Intel(R) Pentium(R) D CPU 3.00GHz
RADEON X850 XT PE (Omega 3.8.360)
Creative Audigy Audio Processor (WDM)
2GB RAM
500GB(2X250) HD

I downloaded ATITOOL0.24 . GPU temp around 50-55 GPU environment about 36-38. looks good. however, When i start BF2. GPU up to 120-130!!! not overclocking yet. 8O I take out the video card, clean the fan. open the case, put 2 fan next to it. update drivers. after all.. still the same. I ran the 3dmark06, couldnt even finish the 3D test. :cry: 

So I'm not sure what to do. is my card broke? I am thinking to buy Thermaltake Tide Water VGA Liquid Cooler . i afraid its gonna be the same.

Any ideas please? I'd really appreciate the help.
June 16, 2007 12:35:01 AM

1. Look at ATiTool and run the "artifacts" test, keep an eye on your temps and your fan speed, i used to have that card and I kept the fan running at 100% at all times.

2. If changing the fan speed doesnt work, put your hand on the fan (not the copper or the board, it may burn you) and just make sure that it is spinning. If its not spinning that your problem, your fan is dead.

I can't think of anything else, it sounds to me as if your fan is not running at full speed when it reaches a certain temperature. If you have dynamic fan speeds on, change it to fixed at 100%.

Good luck, that's a solid card, I had the AGP flavor, but now I'm rockin an 8800GTS 640.
June 16, 2007 1:23:46 AM

Is your fan speed turned up all the way?

The stock fan speed on may X850 series cards was only 5% unless they reach really high temps (like 90C+).

Go into ATITOOL's fan control settings and override the fan settings and make sure it's at 100% at all times.
!