Sign in with
Sign up | Sign in
Your question

Truecrypt 7.0

Last response: in Apps General Discussion
Share
December 27, 2010 1:48:49 PM

Hi

I'm new to this encryption thing. I have downloaded TrueCrypt 7.0; it's fairly simple to use. I created a TrueCrypt volume container - a kind of file - which can mounted as a virtual drive.

The issues I have with TrueCrypt volume container encryption are:

1: anyone can delete the container which would mean that someone can simply delete the encrypted file (container) out of frustration and I'm the one who is going to suffer
2: anyone can copy the container; though one should have the password to use it
3: reformat the flash drive which would have the same consequences as in (1) above.

Is there any way to solve these issues? Please let me know. Thank you.

More about : truecrypt

a b 8 Security
December 27, 2010 4:13:53 PM

1. set file rights on the file to make it undeletable or setup user accounts that only have rights to get to the file.
2. see above
3. see above

You can't really block against formating and deleting the file. Encryption is meant to protect the data stored from unauthorized viewing not from it being deleted. If you are worried about the data, make backups of it.
m
0
l
December 27, 2010 5:00:36 PM

Thank you for the reply, HangThe.

How do I make it undeletable? I couldn't find this feature. Please let me know. Thanks.
m
0
l
Related resources
a b 8 Security
December 27, 2010 5:54:49 PM

haroonahmad said:
Thank you for the reply, HangThe.

How do I make it undeletable? I couldn't find this feature. Please let me know. Thanks.


For only not being able to delete, right-click on the file, go to Security, click on Advanced. Select the user account you want to change rights for (I strongly suggest you don't touch SYSTEM rights), click on Edit. In the list you will find Delete rights.
m
0
l
December 27, 2010 6:59:22 PM

Thanks. I'm using Win XP. When I right-click the file I don't find the Security in the list. Perhaps, the feature is only available in later systems. Could you please confirm it?
m
0
l
a b 8 Security
December 27, 2010 7:35:17 PM

haroonahmad said:
Thanks. I'm using Win XP. When I right-click the file I don't find the Security in the list. Perhaps, the feature is only available in later systems. Could you please confirm it?



Are you running Pro or Home? Security options have been available in Windows for quite some time now, XP has it.
m
0
l
December 27, 2010 8:21:15 PM

Hi Hang

I'm running Win XP Pro SP2.
m
0
l
a b 8 Security
December 27, 2010 8:30:16 PM

Turn off Simple File Sharing. Open any folder, go to Tools, Options, View. Scroll to bottom and uncheck "use simple file sharing. You should now see the Security tab.
m
0
l
December 28, 2010 11:14:18 AM

Thanks a lot, Hang. It's there now. I would continue this thread if I had more queries related to this. Once again, thanks.
m
0
l
!