Sign in with
Sign up | Sign in
Your question

My Memorex Dual Format DVD Drive won't let me burn or read.

Last response: in Storage
Share
June 16, 2007 8:37:07 PM

I have a Memorex Dual Format DVD +/- RW drive (part number 3202-3235) and it won't let me burn or read DVD's (movies or data). When I got it, 3-4 years ago, it worked fine when I installed it. I don't recall if there was a driver CD that came with it, but I don't have one anymore. Anyway, I recently completely reinstalled my Windows XP system to start clean. From that point, my DVD drive worked limitedly. It could burn data and video DVD's, but it couldn't read them reliably (it could read commercial data DVD's, like games, but it couldn't read anything else). So I went to the Memorex website and got the drivers and everything, but my drivers were already up to date. I called memorex, and they sent me a CD with a bunch of useless Nero software claiming it would fix my problem. It didn't. Actually, after I installed their CD, the problem got worse. Now my DVD Drive won't do anything. I won't read or write. I uninstalled the driver and restarted. I got the firmware from memorex and tried to flash it, it said it found the target device, but it said the firmware was already up to date. I got every update (critical and non-critical) from Windows Update online. None of this helped. So now I don't know what to do. Any suggestions?

Thanks!
June 16, 2007 9:18:44 PM

try a differnet IDE cable, something similiar happened to me recently.
June 17, 2007 2:59:24 AM

Thanks for the response.

Unfortunately I don't have a spare IDE cable around. But I don't think that would work anyway. I've got my CD Drive and my DVD Drive both connected with the same IDE cable, and my CD Drive works fine. Also, my DVD drive reads and writes fine for CD's. It just doesn't work for DVD's. So data is moving fine.

I did, however, try jiggling around the IDE cable and the power cable, to no avail. I also tried rebooting my system with the DVD Drive unplugged, then rebooting with it plugged in, but that didn't help either.

Any other suggestions?
!