Vista 64 msdtc console failed to start after restore

When Vista started after a complete PC restore from an image created in Vista the system booted fine. Then in about a minute I see a windows error message that says MSDTC Console Failed to Start .... As MSDTC runs as a service, I opened: control panel, administrative tools, services, and attempted to restart Distributed Transaction Coordinator. The result was Error 1067 service failed to start unexpectedly. I have tried most of the checks of the registry values recommended on various web sites but have found no missing entrys. I have tried msdtc -uninstall, mstdc -reinstall and I cannot be sure these are working as they take no time to complete.

Any help on this issue would be appreciated. Someone with much more knowledge than I might be able to understand Mark K Vallevand article where he says he has a fix for this problem on this site: http://www.generation-nt.com/us/msdtc-problem-fixed-help-49431852.html

I have very moderate windows skills, any help is appreciated. I could reinstall Vista but would like to avoid it if possible.
3 answers Last reply
More about vista msdtc console failed start restore
  1. Extract from http://www.tomshardware.com/forum/237785-44-console-error-start-vista-restore

    The error code -2147024894 (80070002) maps to "Path not found". It looks like one or more security registry values are missing. Can you check if the following registry values are present on your machine:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC\
    AllowOnlySecureRpcCalls [1] REG_DWORD
    FallbackToUnsecureRPCIfNecessary [0] REG_DWORD
    TurnOffRpcSecurity [0] REG_DWORD

    HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC\Security
    AccountName [NT AUTHORITY\NetworkService] REG_SZ
    DomainControllerState [0] REG_DWORD
    NetworkDtcAccess [0] REG_DWORD
    NetworkDtcAccessAdmin [0] REG_DWORD
    NetworkDtcAccessClients [0] REG_DWORD
    NetworkDtcAccessTransactions [0] REG_DWORD
    NetworkDtcAccessInbound [0] REG_DWORD
    NetworkDtcAccessOutbound [0] REG_DWORD
    NetworkDtcAccessTip [0] REG_DWORD
    XaTransactions [0] REG_DWORD

    If there are missing values, can you recreate them, set them to the default value which is in brackets[], and then run msdtc.exe -install.

    Note you need to run msdtc.exe -install
    Click start run.
  2. I tried all of the fixes indicate by both posts above. I finally gave up and reloaded Vists 64. All is OK now but If someone knows of a for-sure fix for this problem I would love to here of it for future reference. Thanks for the help.
Ask a new question

Read More

Consoles Windows Vista