Sign in with
Sign up | Sign in
Your question

Windows keeps installing HD Audio drivers-disables my sound card

Tags:
  • Drivers
  • Audio
  • Sound Cards
  • Windows 7
Last response: in Windows 7
Share
August 12, 2011 4:45:53 PM

I have an Echo MiaMIDI sound card for recordings, when i first installed it i had to disable my motherboards onboard sound through my bios before windows would use it. This has been fine for 2+ years.

Windows 7 (64 bit home premium) has suddenly started installing the "HD Audio Device Drivers". I dont understand this since I have all windows updates turned off. But when it installs these audio drivers it disables my Echo MiaMIDI card.

So i go to device manager and it shows the Echo card but says there is not enough resources to use it due to other drivers being used, and it lists the HD Audio Device being in use. So i uninstall it but moments after this Windows starts installing it again. It still says disabled in my bios. its driving me crazy because i cant use my sound card!

More about : windows installing audio drivers disables sound card

November 11, 2011 10:34:20 PM

jbourne84 said:
I have an Echo MiaMIDI sound card for recordings, when i first installed it i had to disable my motherboards onboard sound through my bios before windows would use it. This has been fine for 2+ years.

Windows 7 (64 bit home premium) has suddenly started installing the "HD Audio Device Drivers". I dont understand this since I have all windows updates turned off. But when it installs these audio drivers it disables my Echo MiaMIDI card.

So i go to device manager and it shows the Echo card but says there is not enough resources to use it due to other drivers being used, and it lists the HD Audio Device being in use. So i uninstall it but moments after this Windows starts installing it again. It still says disabled in my bios. its driving me crazy because i cant use my sound card!


Hey there, I don't know if you figured this out yet but I was pulling my hair out with the same issue for weeks. I almost sent the computer in to the manufacturer but I kept thinking, no, there must be SOME easy fix for this stupid driver update!
Finally the other day I disabled automatic updates by going START > Change Device Installation Settings > Do no automatically update.

That has fixed the issue for me.
m
0
l
a b \ Driver
a b $ Windows 7
November 11, 2011 10:57:17 PM

Du have any update utility running? That could update it for u by itself.

Do u have the patch installed?
http://echoaudio.com/Downloads/Misc.php
m
0
l
a b \ Driver
a b $ Windows 7
November 11, 2011 10:58:11 PM

Try to disable the auto-update in the program, if there is any.
m
0
l
April 11, 2013 11:52:04 AM

Ok, I have ran into this same problem. This is how you do it.

Go to Start and type in "services.msc"

A dialog box will pop up. Now, look for 'UPnP Device Host' and right click on it and to to properties see startup type (drop down box)? Select disable and if it is still running stop it. Now, there are two other intrusive options I took off too, which have no place on anyone's OS. (F you Bill Hates).

Second thing you look for is 'SSDP Discovery' provides licensing notification, blah blah blah... DISABLED!

And last but surely not least, the most infuriating thing about win 7 64 bit and up... the unapproved license BS. Where you can't install drivers that are unlicensed by MS. That option is right above the last and is called 'SPP Notification Service' same process as the ones above.

You can disable many BS things about windows in this area but be careful because you wouldn't want to disable something really important.

m
0
l
September 14, 2014 1:51:56 PM

jbourne84 said:
I have an Echo MiaMIDI sound card for recordings, when i first installed it i had to disable my motherboards onboard sound through my bios before windows would use it. This has been fine for 2+ years.

Windows 7 (64 bit home premium) has suddenly started installing the "HD Audio Device Drivers". I dont understand this since I have all windows updates turned off. But when it installs these audio drivers it disables my Echo MiaMIDI card.

So i go to device manager and it shows the Echo card but says there is not enough resources to use it due to other drivers being used, and it lists the HD Audio Device being in use. So i uninstall it but moments after this Windows starts installing it again. It still says disabled in my bios. its driving me crazy because i cant use my sound card!



Based off the other solutions I found this from microsoft. Includes some of the other solutions

http://support.microsoft.com/kb/2500967
m
0
l
!