Sign in with
Sign up | Sign in
Your question

Deathadder 3500 driver problem

Last response: in Windows 7
Share
August 12, 2011 8:36:49 PM

Hello!
I'm Mark and I received my Razer Deathadder today.
As soon as I plug it in, Windows 7 automatically downloads a driver and installs it.
The problem is, it isn't the correct driver. It's actually the one for the old Deathadder, not the new 3500DPI one which I have.
The mouse does work, but none of the options in the Razer Deathadder driver work.
For instance, I turn off the scrollwheel light in the application and press apply, and nothing happens.
If I download the latest, correct driver from the Razer site, version 3.0.3, it installs, but on the next boot the mouse doesn't do anything. I then have to uninstall the driver, reboot, plug the mouse out and back in so that windows automatically downloads the working driver.

I have tried a TON of solutions to this problem, including:
1: I tried disabling some services to prevent the driver from downloading (Windows update, windows modules installer, upnp device host)
2: I tried disabling windows from automatically installing drivers
3: I tried uninstalling the driver, deleting the windows driver files for the mouse in system32/drivers, then unplugging my internet and rebooting, but STILL it manages to say 'installing driver' as soon as I start
4: I tried manually updating the firmware trough device manager

NON of these solutions work!
I really want to use this mouses' special features such as the 1000Mhz polling rate, 3500DPI, but these have to be activated trough the driver which doesn't install.

ANY help would be appreciated, since this is driving me insane.
Thanks in advance,

-Mark

[edit]
My system specs are:
ASRock P67 Extreme4
Core i5 2500k @ 4.2Ghz
MSI r6870 HAWK @1Ghz core, 1200Mhz memory
Western digital 1Tb
4Gb corsair value select.
Windows 7 Ultimate

The mouse is plugged in trough my USB 3.0 port
[edit]
August 15, 2011 1:57:02 AM

I also have this exact same problem. I've used the 1800dpi deathadder and I can't get the new drivers to recognize my mouse.

This is NOT the problem where the firmware kills the mouse and causes it to not be recognized. Every time I replug it in I have to re-download drivers through windows the the mouse works.

OP, or anyone else with the same issue, have you guys found a fix for the problem? I'd love to use the additional features.
m
0
l
August 15, 2011 1:58:48 AM

In addition to everything you've tried above I've also tried to roll-back the drivers to the 3.02 version. I still have the same problem and I can't get it to work.

OP, have you tried installing drivers on another computer? Perhaps there's some hidden registry file we're not deleting.
m
0
l
Related resources
February 23, 2012 10:17:49 PM

I have the same Problem! :fou:  Is there an answer? :hello: 
m
0
l
March 9, 2012 1:58:38 AM

I found the answer!! I was so frusterated but I found the answer! It's the USB 3.0's You have to use 2.0's but now I'm having a problem where it flickers but I think reinstalling the divers will fix it
m
0
l
!