Solved

Intel Desktop Utilities UI not showing

Hello. I installed Intel Desktop Utilities on my machine (Win7 32-bit). The application shows up on the system tray but when I try to open the application's main window, nothing shows up, though I can see an "intelmain.exe" in the task manager. Has anyone encountered the same problem?

I'm running on Core i5-2500K with an Intel DH67BL board and 4GB RAM.

Thanks,
Mark
6 answers Last reply Best Answer
More about intel desktop utilities showing
  1. I have exactly the same problem with Win7 64-bit on a Core i5-2500K with an Intel DH67BL board and 4GB RAM

    I am using an administrator account, but after allowing the program to run, nothing happens. Can't get anything except help running when I right click the program in the system tray.
  2. Have looked it up on Intel community forum

    http://communities.intel.com/message/115217#115217

    The German speaking dude said it was fixed when he updated his BIOS.

    I'll try it.
  3. Best answer
    Yes, the German speaking due was correct for this board DH67BL. This may not work for other intel boards.

    Updating the BIOS from 0076.2010 to 0098.2011 worked flawlessly, have now access to the utilities.

    I downloaded and ran BLH6710H.86A.0098.EB.EXE fro the intel download center
    http://downloadcenter.intel.com/default.aspx

    worked like a breeze right out of windows (didn't have to burn a CD or nuthin)
  4. Thanks, collinsej!

    OT:
    I read Intel has started its recall on the boards affected by the Sandy Bridge chipset flaw. I hope updating the BIOS won't cause issues with the regards to getting the replacement.
  5. Best answer selected by markrgli.
  6. Hi I have the same problem with installation desktop utilities. Thanks for good answer markrgli.
Ask a new question

Read More

Desktops Intel Apps