Sign in with
Sign up | Sign in
Your question

All web browsers crash "randomly"

Last response: in Social Networking
Share
February 13, 2011 10:33:31 AM

Hi,

The basic premise is that all web browsers I have tried this far crash or report an error within a few seconds or a minute of using them. It seemed likely that it was an issue with a plug-in or an add-on like the flash player or shockwave, Firefox would for example complain about that. And all browsers would always crash if I tried to play some kind of online game (web browser flash game). But I have tried uninstalling flash and installing it again, to no avail. I have also started internet explorer without any add-ons, and the problem still persists.
At first I thought it might have been some kind of malware, but I have searched the computer thoroughly with AVG, MSE, Malware bytes and none of them have found anything. Finally, I gave up and and reinstalled Windows 7. But the problem persists.

The computer is running Windows 7 Home Premium 64-bit
AMD Phenom II 550 x2 black edition (unlocked to a x4)
4GB RAM
Radeon HD 5770
(Seems very unlikely that it would be a hardware error)

The error logs have been pointing to ntdll.dll and kernel32.dll in most cases, and in a few instances KERNELBASE.dll. This is for IE8 at least. The crash logs for chrome would report chrome.dll and for firefox I dont remember because I haven't installed it yet (reinstalled the OS). Here are a few examples of related crash logs (in swedish, unfortunately):

Felet uppstod i programmet med namn: iexplore.exe, version 8.0.7600.16385, tidsstämpel 0x4a5bc69e
, felet uppstod i modulen med namn: ntdll.dll, version 6.1.7600.16385, tidsstämpel 0x4a5bdb3b
Undantagskod: 0xc0000374
Felförskjutning: 0x000cdcbb
Process-ID: 0x4ac
Programmets starttid: 0x01cbcb700faed4db
Sökväg till program: C:\Program Files (x86)\Internet Explorer\iexplore.exe
Sökväg till modul: C:\Windows\SysWOW64\ntdll.dll
Rapport-ID: 5d08fdef-3763-11e0-a69b-bcaec51ee7f1

Felet uppstod i programmet med namn: iexplore.exe, version 8.0.7600.16385, tidsstämpel 0x4a5bc69e
, felet uppstod i modulen med namn: KERNELBASE.dll, version 6.1.7600.16385, tidsstämpel 0x4a5bdbdf
Undantagskod: 0xc000001d
Felförskjutning: 0x0000b727
Process-ID: 0xf04
Programmets starttid: 0x01cbcb6fc34b7036
Sökväg till program: C:\Program Files (x86)\Internet Explorer\iexplore.exe
Sökväg till modul: C:\Windows\syswow64\KERNELBASE.dll
Rapport-ID: 0127969b-3763-11e0-a69b-bcaec51ee7f1

I have been googling this issue like crazy and most of the solutions are concerned with add-ons or plug-ins. It might have to do with an installed program, but it seems veru unlikely. I have never ecnountered this issue with other computers having pretty much the same programs installed. Or perhaps there is an issue with this particular instance of Windows 7, i.e there is something wring with the install DVD?

I think I have provided you with enough info, but please tell me if there is something else you would like to know.

Thanks!

/S
February 13, 2011 12:14:23 PM

I should point out that I have noticed that the 64-bit edition of Internet Explorer seems to be functioning perfectly. Also, During the last few hours windows has crashed to BSOD two times with the message APC INDEX MISMATCH. I cannot tell if the crashes are linked to some activity or application. Is it possible that this error is linked to the above?

Related resources
February 27, 2011 3:30:41 PM

Ok, I ran the Memtest86+ v4.15b from Hiren's BootCD and it did actually return one error, surprisingly. I have very little knowledge of what types of errors occur in RAM and the paging structure and all that, so please enlighten me if the following error information can tell you something of value:



Tst: 6

Pass:11

Failing Adress231: 0004d967978 - 12414MB

Good: 00010000

Bad: 00000000

Err-bits: 00010000

Count: 1

Chan: (blank)



The memory sticks are a pair of 2GB Corsair Value Select DDR3 1333MHz:

1.5 volt

240-pin

latency: 9-9-9-24

No ECC



The memtest ran for 26hrs with a total of 26 passes. Some other information that was shown:

RsvdMem 160k

MemMap e820



Can the problem be due to the lack of ECC? What kind of error is it?



Thanks!
February 27, 2011 6:18:43 PM

If your RAM is showing even one error you want to find out which stick it is. Normally you want to take one stick out and run the test again. If it errors out its the bad one. If not, run the next stick.

Not having ECC would not cause Memtest 86+ to error. ECC is only for memory in servers that need every single last bit to be right. Desktops don't need that kind of correction.
February 28, 2011 10:29:41 AM

Right, so there's no way of telling which stick is the faulty one? Well, probably not now that I think about it, the adress where the error is in could belong to either of the two. But does it really matter which one is the faulty one? Since they come in a pair I could probably send them back to corsair with the warranty, they're just a few weeks old.
March 2, 2011 1:58:30 AM

Yea Corsair has a good warranty. I would just return them and get new ones. Then make sure to run Memtest again for about 8 hours to get a good pass.
March 21, 2011 5:41:40 PM

I just installed the new RAM-sticks that I got back from Corsair and the problem still persists. I'll run another memtest just to make sure that the memory sticks are fine. But it's very unlikely that they too would be faulty.

What may be the next step? Could it be that the actual operating system installation is faulty? Or perhaps the GPU...?
April 21, 2011 5:20:09 PM

You are not alone in the browser crashes. Both my firefox and ie started crashing this morning. There seems to be no pattern to why they are crashing. I'm guessing there is some malware hidden on my system (despite all my scans coming back negative). But I still can't figure out why this is happening. I've tried dissabling addons in both browsers but that didn't change anything. I've run memory and other system tests, but all results are normal (no errors).

Hopefully someone see's this thread and has an answer for us!
April 22, 2011 9:10:00 AM

What finally solved my problem was something as simple as resetting the CMOS memory in BIOS. I think the problem was that I had unlocked two extra cores.

what error messages do you get after crashes?
April 22, 2011 7:16:58 PM

I've seen your other posts around the web while doing my own research. I've tried everything you've done as well with no luck. Resetting my BIOS was something I tried last night, but still no luck.

BUT, I might have just fixed it. I've been messing with Java and Flash since it seems to be the most common 'answer' people are giving for this. I'd uninstalled, reinstalled, reg-cleaned and completely washed my system of these two programs, but no luck... until I uninstalled Flash and LEFT it uninstalled. I've been surfing around on both my Firefox and IE9 browsers for a few hours now and haven't crashed once.

I haven't tried to re-install Flash yet to see if it starts crashing again or not, but will be trying that shortly.

As for error messages, I only have the report details for my IE crashes (see below) and since Firefox hasn't crashed again, I can't copy it's report details yet. If I get it to re-crash I'll post them though.


IE9 Crash Report
Source
Internet Explorer

Summary
Stopped working

Date
‎4/‎22/‎2011 2:31 AM

Status
Report sent

Description
Faulting Application Path: C:\Program Files\Internet Explorer\iexplore.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: iexplore.exe
Application Version: 9.0.8112.16421
Application Timestamp: 4d76255d
Fault Module Name: StackHash_a7aa
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 00014ea3
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: a7aa
Additional Information 2: a7aa91f17ea749d42a4de3b390fa5b3d
Additional Information 3: a7aa
Additional Information 4: a7aa91f17ea749d42a4de3b390fa5b3d

Extra information about the problem
Bucket ID: 2354425469
May 2, 2011 5:02:34 AM

I finally got to save a Firefox crash detail. See below.

In addition, I've restored my computer to from a back up I made 1 month ago, before these problems even started. I've done the restore twice, but I still have the same problem on restart. I'm wondering if there is a virus or something that has gotten into my MBR (which isn't overwritten on the backup restore) that is causing this issue??


Firefox Crash Detail (note this is version 3.6.15, the version I had when I made my backup. The crashes were happening even with the most current version 4 before I did the restore):

Add-ons: {22119944-ED35-4ab1-910B-E619EA06A115}:6.9.98,{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:1.3.3,{47624dda-b77e-4feb-820a-e4f077d5d4ca}:11.0.0,{1cff04ef-0c75-4621-ba2a-2efb77346996}:2.3,{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}:0.9.8,firefox@facebook.com:1.6,{bee6eb20-01e0-ebd1-da83-080329fb9a3a}:0.1,{ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a}:1.4.1,{CAFEEFAC-0016-0000-0018-ABCDEFFEDCBA}:6.0.18,noia2_option@kk.noia:3.76,{AE93811A-5C9A-4d34-8462-F7B864FC4696}:3.81,{a7c6cf7f-112c-4500-a7ea-39801a327e5f}:1.0.10,{ABDE892B-13A8-4d1b-88E6-365A6E755758}:1.1.3,{340c2bbc-ce74-4362-90b5-7c26312808ef}:1.7,{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}:2.12.21.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.6.15,{9f08cb5a-76b1-4bcf-aff9-90e1a5d60b1e}:3.76
BuildID: 20110303024726
CrashTime: 1304312313
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1300042552
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 30793634
StartupTime: 1304312286
Theme: Noia2f
Throttleable: 1
URL: http://oca.microsoft.com/en/windiag.asp
Vendor: Mozilla
Version: 3.6.15

This report also contains technical information about the state of the application when it crashed.
May 23, 2013 3:10:06 AM

I have a similar crash issue, too. I wonder if you guys have the crash effecting all the system, even the caps-lock light and need a hard-reset? My crash starts with the mouse cursor slow-down and ends up with the whole system freezed.
June 2, 2013 9:06:54 AM

From this page:http://forums.techguy.org/windows-7/1032392-solved-all-browsers-crashing-windows.html

"TCP/IP stack repair options for use with Vista or 7.

Start - All Programs - Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine."


This works very well. I don't know why it's not fixed in a patch from Micro$oft.

!