Sign in with
Sign up | Sign in
Your question
Closed

D-link DWA 556 Wireless Adapter Driver question

Last response: in Windows Vista
Share
February 23, 2010 7:01:02 PM

Hi, Ill start with a little back story:
I bought a new DWA 556 wireless adapter about three days ago and i originally just used the CD to install drivers and so forth. I noticed that the internet seemed to be a lot slower compared to my other wireless computers (laptops) and it would also randomly disconnect. The internet i have right now is already pretty bad but the one with the new card seems to be worse.

After looking up some solutions, i read that the d-link drivers are super oldand not up to date so i looked up some drivers to download and went to station-drivers.com to download the VISTA 64 bit drivers. after installing it my internet seemed to be even worse before and still dropped (within 5 minutes of installing it). i looked into it and someone wrote that the vista drivers are always faulty and to use the XP driver even when using vista because they work better and dont drop, but when i downloaded the XP drivers and went to update drivers, it said the driver software could not be found, even though i selected the folder and extracted all of it into that folder.

If you guys know whats wrong and could point me in the right directoin i would be greatly appreciative! thanks a lot! oh and here is the full url to the website i dl'd the drivers from

http://station-drivers.com/page/atheros.htm

Someone said the 802.11n use AR5008 drivers so i choose the driver under that one. thanks a lot!
a b \ Driver
February 24, 2010 12:34:57 AM

Generally Before updating any device drivers, it is a very good habit to clear the old drivers from the system!
Use Driver Cleaner Pro 1.5!
http://downloads.guru3d.com/download.php?det=745

Remove all your old drivers &Restart & try again!

If you are using 64 bit vista, and trying to install 32 bit drivers, it will also cause problems!

Download the drivers & fixes directly from here by selecting region & proper OS!
http://www.dlink.com/products/default.aspx?pid=DWA-556&...

Your problem will be surely solved!
January 15, 2012 1:01:21 PM

The D-link drivers are not that great... the dlink forums say to use the atheros drivers to get the card working consistently...


@OP:

The latest atheros version for the AR5008 card is Version 9.2.0.462 WHQL for windows 7 32/64bit dated 22/12/11...

I downloaded and installed the drivers (running the setup.exe in the extracted folder, which win7 seems to have installed fine as looking in device manager, the card (under the section for Networking) seems to be using the atheros driver (which is dated 22/10/11)... here's hoping this doesn't have any more problems *crosses fingers*...

!