Sign in with
Sign up | Sign in
Your question

very strange connectivity problem - wired and wireless

Last response: in Networking
Share
January 18, 2008 9:09:19 PM

Hi,
I have a networking issue, both with wireless and wired connection.

Using wireless, what happens is that after rebooting I get connected immediately without problems to my router, get and IP and all (DHCP, reserved address at the router, set to “WPA or WPA2”, using latest atheros drivers, using windows to manage my connection).

Pings time-out to the router (gateway=192.168.0.1), I have no connectivity at all even though the card connects to the router OK. If I do ipconfig /release then /renew then I get excellent pings to the router ( 1 ms) but no pings to my desktop which is connected to the same router (with ZA properly configured, and in any case the same happens without ZA). Needless to say, no internet connectivity. The funny thing is that if I wait a couple of minutes and retry the ping to the gateway, it times out again. If I do ipcongif /release --> /renew, I get good pings again for 1-2 mins. I tried with the asus provided drivers, with the WHQL .56 drivers and with the newer (non-WHQL) ver 6 drivers which I’m using now. Also, if I do "repair connection", the process completes perfectly and the wireless reconnects to the router, but pings to the gateway still time-out until I release-renew. Only ipconfig clears them, and as said only for a minute or so. What's more, when I'm still able to ping my gateway, if I try pinging www.yahoo.com, the ping times out but the DNS is resolved to the full name and IP address of the server. A last test I did, after /release  /renew, I pinged my gateway with the –t modifier, so that it continue pinging until I stop it. It went on for 5 minutes without stopping, so it seems that the “pingability” is lost after 1-2 min of idling.

For the record, my the eeePC “laptop” does not have a firewall running (I installed comodo to use when I’m using networks outside my home but it's disabled now), my desktop whose wifi adapter is 40 cm from my eee PC connects perfectly to my router, there are between 3-6 other networks around at any given time, but they've never been an issue (not with my desktop, my wife's desktop 3 meters from mine nor with the eee pc before my previous eee-PC saga began, which after being solved I got this new pearl). I'm using a brand new D-Link DIR 635, latest firmware. My eee PC is win XP SP2 fully updated, stock ram, eeeclock running at 100 MHz stable, BIOS 703 (latest).

Still, but it turns out it's more complicated than *just* that. I connected to the router directly with a cable using the ethernet port, and it turns out the very same thing happens with the ethernet connection! I get the IP address but no pings to the gateway, IP /release --> /renew gives gateway pings that last only a minute or so. No internet. Awfully strange!!!

My ipconfig /all looks exactly the same as the one in my main PC (except the obvious differences in name and IP address), FWIW here it is:
Windows IP Configuration

Host Name . . . . . . . . . . . . : Uriel-eeePC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros L2 Fast Ethernet 10/100 Base
-T Controller
Physical Address. . . . . . . . . : 00-1E-8C-5E-29-DB
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.121
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : Friday, January 18, 2008 11:14:40 PM

Lease Expires . . . . . . . . . . : Saturday, January 19, 2008 11:14:40
PM

Just to consider installing XP for the 3rd time brings tears to my eyes... and all that after 2 w of toying with xandros and learning linux only to reach the conclusion I'm better off with XP...

Therefore, it seems that it could be that the wireless card is not the problem at this moment but some TCP/IP problem related to windows itself, since both wireless and wired connections connect without problems and pass tests and both exhibit the same problem.

I reset the TCP/IP stack and the winsock according to the microsoft KB articles but nothing changed.

I’m all out of luck and ideas. Any help will be greatly appreciated!

Thanks,

UTKcito.
April 13, 2009 2:25:14 AM


I have the same exact issue as you have on my 1000HA, I cannot figure out for the life of me what the problem is.
I tried the latest non-official wireless drivers from atheros and still the same issue. I can ping the internet but not my gateway or computers on my lan, and the internet times out after a few minutes. I use WPA, it seems to be related to encryption as if I change my wlan to open (no encryption) then it works fine, but that's not a solution.

I'd be interested to see if you found the answer.

Thanks,
Chris
!