FarCry Installation on Vista 64 SP1 or SP2

I haven't been able to get this to install on my HP V64 w-ATI 3200. I tried Compatability mode XP on setup.exe...No go! It's one of my favorite Tacs. What too dooo!
1 answer Last reply
More about farcry installation vista
  1. You'll find the minimum and the recommended system requirements here...
    http://farcry.us.ubi.com/help/pc/readme/readme.txt

    HP V64 does not compute. What model of HP do you have?
Ask a new question

Read More

Configuration Hewlett Packard Windows Vista Windows XP