Sign in with
Sign up | Sign in
Your question

Problem with 7300GS

Last response: in Graphics & Displays
Share
June 21, 2007 1:07:28 AM

Herro friends,

My 7300GS is malfunctioning, I think. It's either that, or the game I want to play. I installed Tom Clancy's Splinter Cell: Pandora Tomorrow, and whenever I try to run it, it goes super choppy (like 1 frame per 5 seconds) so I figured something had gone awry during the installation. Upon reinstalling, I recieved the same error. So I went into the configuration & diagnostics tool, and it apparently says that I'm missing something called "Non-power-of-two Render Target Support" what the hell is that? I can run games like Far Cry and Doom3 just fine, but this and Deus Ex: Invisible War are giving me the exact same problem (Except Deus Ex doesn't actually say it, it just loads freakishly slow). So, guys, how do I fix this?

More about : problem 7300gs

a b U Graphics card
June 21, 2007 1:34:35 AM

You need to patch Splinter Cell.

The NP2 texture support error is a message from the system when checking the caps for support and flagging it for the game, it's telling you but not telling the game how to act, without the patch the game likely doesn't know what to do with texture compression or filtering and that would explain the terrible performance. The GPU supports it but the software doesn't recognize it. Seems patching it fixes the problem.

BTW a non-power-of-two/NP2 would be something that's not 2,4,8,16,32,64,128, etc per side trexture, like 3x3.
June 21, 2007 4:16:14 AM

Quote:
You need to patch Splinter Cell.

The NP2 texture support error is a message from the system when checking the caps for support and flagging it for the game, it's telling you but not telling the game how to act, without the patch the game likely doesn't know what to do with texture compression or filtering and that would explain the terrible performance. The GPU supports it but the software doesn't recognize it. Seems patching it fixes the problem.

BTW a non-power-of-two/NP2 would be something that's not 2,4,8,16,32,64,128, etc per side trexture, like 3x3.


That worked somewhat, but I have another issue now... the game is running slowly. Not FPS-wise, but it's in slow-motion. The graphics are really clean, smooth, and the FPS is high, but the game lags considerably and it doesn't really work. I tried setting the graphics settings on the lowest, same thing. Doesn't do a thing. The 7300GS should be more than enough to run this game, but it seems as if they two are clashing. Any ideas?
Related resources
June 21, 2007 5:18:24 AM

Quote:
You need to patch Splinter Cell.

The NP2 texture support error is a message from the system when checking the caps for support and flagging it for the game, it's telling you but not telling the game how to act, without the patch the game likely doesn't know what to do with texture compression or filtering and that would explain the terrible performance. The GPU supports it but the software doesn't recognize it. Seems patching it fixes the problem.

BTW a non-power-of-two/NP2 would be something that's not 2,4,8,16,32,64,128, etc per side trexture, like 3x3.


That worked somewhat, but I have another issue now... the game is running slowly. Not FPS-wise, but it's in slow-motion. The graphics are really clean, smooth, and the FPS is high, but the game lags considerably and it doesn't really work. I tried setting the graphics settings on the lowest, same thing. Doesn't do a thing. The 7300GS should be more than enough to run this game, but it seems as if they two are clashing. Any ideas?

make sure that you have the latest Nvidia Forceware.

Try running at a display resolution of 800x600. Make sure that you arent using AA or AF.

If it doesnt work, then perhaps its being bottlenecked by your CPU or ram. If you have less than 512mb of system memory it will significantly bottleneck the PC.

Good luck
June 21, 2007 5:37:23 AM

Quote:
make sure that you have the latest Nvidia Forceware.

Try running at a display resolution of 800x600. Make sure that you arent using AA or AF.

If it doesnt work, then perhaps its being bottlenecked by your CPU or ram. If you have less than 512mb of system memory it will significantly bottleneck the PC.

Good luck


I have 2gb dual channel RAM, and an E6420 Core2 Duo.

The Forceware drivers were up to date, but I reinstalled them anyways. Resolution lower with AA/AF off helps slightly, but it's still choppy. I set the 3D settings to "Application controlled" on the driver, and tried tinkering around with it a bit. Nothing has worked so far :( 
June 21, 2007 7:12:10 PM

Bump for halp pls :(  Someone here must know the solution
!