Sign in with
Sign up | Sign in
Your question

How to fix working windows host application ati catalyst control centre

Last response: in Windows Vista
Share
Anonymous
a b \ Driver
March 18, 2010 11:13:32 AM

how to fix ati catalyst contol, it has stopeed working,,
a b \ Driver
March 18, 2010 11:50:49 AM

What you did before it sopped working??
Installed/updated drivers??

Find the shortcut of the program in Start >all programs & click on it!

Or remove the older version of the catalyst control center & Download latest version & install!
http://game.amd.com/us-en/drivers_catalyst.aspx
June 22, 2011 9:59:37 PM

It was a bit difficult to figure it out, but during a couple of days I fixed the problem. I have a DELL laptop windows 7 system with AMD64 duo core and ATI videocard.
First of all you need to download driver sweeper ( just google it) and also the driver of your ati videocard. In my case I got my DELL driver update and that include catalyst also. If it is not included download catalyst, but a very early update.

OK. now uninstall all of Catalyst/ATI components and also the driver from your ati video card.

uninstall Catalyst/ATI components by going to control panel and then programs.
Uninstall ati videocard by going to control panel and device manager.

Now you install driver sweeper.

Restart your system in safe mode without network. A allround video driver is now installed.

Use driver sweeper and choose to clean AMD video driver.

Restart your system again to normal mode.

Now install catalyst and restart system.

Now it is working again

Related resources
August 11, 2011 4:34:06 PM

Peter31,

I followed your advice and performed each step as you recommended. It worked very well. Thanks for taking the time to post that. You saved me a lot a additional hassle. I have used CCleaner for a long time, but I look forward to adding Driver Sweeper to my list of tools.

System was Gateway GT5692 Triple Core AMD; VISTA Home Pro 64-bit w/ ATI Radeon 3xxx
January 10, 2012 12:37:49 PM

Step 1 : Go to Task Manager -> Services -> Show All Services

Step 2 : Search for Windows Presentation Foundation Font Cache 3.0.0.0

Step 3 : Right Click on it -> Properties

Step 4 : In General Tab, Change Startup Type as "DISABLED"

Step 5 : Apply Changes.


Reference :
http://social.technet.microsoft.com/Forums/en-US/w7itpr...

Hope it helps !
!