Sign in with
Sign up | Sign in
Your question
Closed

Need help removing a bad driver from my Win7 x64 system

Last response: in Applications
Share
April 21, 2011 11:02:16 PM

I for some reason decided to cheap out and use one of my PS3 controllers as a gamepad on my PC. Great, right? Too bad no good driver exists for the controller, but I didn't know any better at the time and decided to install this pile of junk: . It's a horrendous mess and has royally screwed up my system. It's completely messed with all my Xinput drivers and now I can't even play a game without Securom accusing me of running something a hacking tool called Ollydbg. Simply put, Xinput is now messed up even though I installed the Microsoft software. I removed everything related to "DS3 Tool" and "MotionInJoy" from the registry as well. Tried all the USB ports on my computer, still the same issue, and it's only when I have a REAL Xinput device connected that Securom refuses to launch the game. This is driving me nuts and really don't want to reformat, yet again, because of this problem. I highly advise anybody to stay away from MotionInJoy. How would I go about removing everything Xinput related so I can reinstall the actual Microsoft software? I think that would be a good start. Any help would be great and thanks in advance.
April 21, 2011 11:12:46 PM

You might be able to find a restore point from before you installed and revert. Assuming, of course, you haven't turned that feature off. Keep in mind you'll lose any other configuration (and data?) changes your made.
Score
0
April 22, 2011 12:05:25 AM

Thanks for the quick reply but I believe to have fixed the issue although it seems to crop up whenever it feels like doing so. I deleted the controller driver, uninstalled the Xbox 360 Accessories software, rebooted, installed the Microsoft software, rebooted, then tried again and it worked just now. I think everything related to MotionInJoy must be gone from your computer, including the registry, before you plug in an actual Xbox 360 controller and install the driver. I bought one of the new black wired controllers because the driver for the Sony controller is horrendous. Come to think of it, I had this issue while I was using the PS3 controller as well but thought it to be related to the Slysoft Clonedrive I had installed. It's ridiculous how many registry entries were left behind by the MiJ uninstaller. I literally had to search for DS3 and MotionInJoy and delete every entry the registry editor found. I highly advise anyone to stay away from MiJ's Xinput emulator unless you want trouble like I had. If I have issues again I shall be back. I really think it's odd that Securom would accuse me of being a hacker for having had an Xinput emulator installed, but then again no technology is 100 percent perfect. Lesson learned, hopefully.
Score
0
Related resources
April 22, 2011 11:25:22 AM

The issue is back, and only seems to happen when I have a controller plugged in. Anybody have any ideas? I sent a support ticket to Securom but they're taking their sweet time to get back to me.
Score
0
April 22, 2011 12:28:35 PM

I'd still use a restore point as the first port of call
Score
0
December 28, 2011 2:02:24 PM

I'm in the same boat and unfortunately a restore point is not an option as all of my current restore points are tainted by this garbage software. Whats worse is that the latest update of the Motioninjoy driver is so messed up DS3 Tool can't even detect my Bluetooth adapter so rolling back the driver with DS3 Tool won't work either.

I'm stuck with a the need for a manual removal process. I've done something like this before in Windows XP, but I'm not sure how to find the offending drivers and settings in Windows 7. A little help for me and others in my position would be greatly appreciated.
Score
0
a b \ Driver
December 28, 2011 2:05:47 PM

Start a new thread.
Score
0
!