Sign in with
Sign up | Sign in
Your question

Problem on my building computer.

Tags:
Last response: in Opinions and Experiences
Share
August 16, 2012 8:44:25 PM

Hey guys, I am just posting on this site really quick because I have a question. I know I may not be in the right section right now, but please help me on this problem. So here's the story.

I bought myself some components to build myself a gaming PC & I got it yesterday. But I put in every cords and wires and it doesn't seem to be turning on. I tried turning on by the MB, and it doesn't seem to be working. I didn't do the breadbox before I put into the case so I don't really know what was bad & good and what the problem was. I tried turning it on with the MB, holding down the power button for at least 20 seconds, my power switch is on on my power supply, and it is plugged into a wall. Here are my current computer specifications.


HDD: Seagate Barracuda 2TB 7200RPM
PSU: OCZ ModXStream Pro 700W Modular High Performance Power Supply compatible with Intel Sandybridge Core i3 i5 i7 and AMD Phenom
SSD: OCZ Agility 3 120GB
CPU: Intel i5-3570K
OS: Microsoft Windows 7 Home Premium 64bit
Graphics Card: ASUS Radeon HD 7850
RAM: Corsair Vengeance 8GB 1600MHz
Motherboard: Gigabyte GA-Z77-D3H
CPU Cooler: Cooler Master Hyper 212+
Case: Cooler Master Storm Enforcer
DVD Burner: ASUS DVD Burner



All I am asking for is answers to how to turn on your computer because mine won't turn on. I'm pretty sure that I have all the wires connected. Please help me guys!
August 17, 2012 6:16:52 PM

Need to double-check the wires. Unless for some reason the power supply is dead or your outlet is dead.

Hopefully you did not reverse anything and cook your system.
m
0
l
!