Sign in with
Sign up | Sign in
Your question

Firefox 4

Last response: in Applications
Share
May 26, 2011 12:51:39 PM

I am using Firefox 4.0.1 from many days. Whenever I launch the browser it checks for updates, compatibility, add-on and etc. Then it launches two tabs: 1. the welcome screen(which used to appear only when it is installed fro the first time) 2. The homepage

I cannot find a way to stop that initial check and the welcome screen. It just appears every time .
Is there any way to stop those irritating things to happen every time?????

Please help

More about : firefox

May 26, 2011 3:25:46 PM

no.. always 2 pages opens...
1. the welcome page
2. my homepage
m
0
l
Related resources
a b È Firefox
May 26, 2011 4:29:49 PM

Yes, but you can have multiple tabs set as a homepage. Check the homepage in the options and make sure it isn't overwritten.

Also, if you have any addons, try temporarily disabling them one by one to see if any of them are effecting firefox.

As an extreme case, you could type "about:config" without the quotes in the URL bar. Accept any warnings, then filter for startup.homepage_welcome_url. Right click on it and select modify. Delete the entire string and click ok. Now restart firefox. By removing this, the update screen may never appear again unless you restore the original value, so do this as a last resort.
m
0
l
May 26, 2011 4:44:53 PM

in_core said:
no.. always 2 pages opens...
1. the welcome page
2. my homepage


First,Do what Hawkeye22 has said.If you are still unable to fix the problem then try the software from the given link,It makes all your browsers homepage Google.com,then you can manually change your homepage from Tools>Options>General>Homepage.

http://download.speedbit.com/RestoreBrowserSettings.zip
m
0
l
May 26, 2011 6:40:11 PM

Hawkeye22 said:
Yes, but you can have multiple tabs set as a homepage. Check the homepage in the options and make sure it isn't overwritten.

Also, if you have any addons, try temporarily disabling them one by one to see if any of them are effecting firefox.

As an extreme case, you could type "about:config" without the quotes in the URL bar. Accept any warnings, then filter for startup.homepage_welcome_url. Right click on it and select modify. Delete the entire string and click ok. Now restart firefox. By removing this, the update screen may never appear again unless you restore the original value, so do this as a last resort.


tried it...dosnt make any difference.... i also tried uninstalling the firefox (v4.0.1) and installed the version 4.0 which works fine without any issue i have mentioned......but after few minutes of use it automatically downloads the version 4.0.1 in the background and installs it......
m
0
l
May 26, 2011 6:54:58 PM

go to google.com then open up the options panel on firefox,and under general tab click use current page,then click ok and restart firefox!
m
0
l
May 26, 2011 7:03:56 PM

SR-71 Blackbird said:
go to google.com then open up the options panel on firefox,and under general tab click use current page,then click ok and restart firefox!


tried it...does not make any change.... still the same
m
0
l
a b È Firefox
May 26, 2011 7:32:14 PM

in_core said:
tried it...dosnt make any difference.... i also tried uninstalling the firefox (v4.0.1) and installed the version 4.0 which works fine without any issue i have mentioned......but after few minutes of use it automatically downloads the version 4.0.1 in the background and installs it......


You went into about:config and removed the value for startup.homepage_welcome_url and it still came up???
m
0
l
May 26, 2011 8:14:13 PM

just go to google dot com amd close out the other tabs and then set in options!
m
0
l
May 27, 2011 3:05:25 AM

Hawkeye22 said:
You went into about:config and removed the value for startup.homepage_welcome_url and it still came up???

yes i did that...no difference
m
0
l
May 27, 2011 3:06:50 AM

SR-71 Blackbird said:
just go to google dot com amd close out the other tabs and then set in options!

yes tried that as well...nothing changes....its like as if whatever i settings i change it does not save....so next time same old thing happens
m
0
l
May 27, 2011 3:06:57 AM

Strange,because that is how i fixed it on my windows 7 pro!I'll look into it some more!
m
0
l
May 27, 2011 3:10:34 AM

i m also shocked...i have tried os many things and theres no solution...
is there any way to remove all my firefox extention and addons when uninstalling firefox....i might try that
but as i said i took that path many days ago but dosen not fix the problem
m
0
l
May 27, 2011 3:12:22 AM

I't should give you that option when you uninstall!
m
0
l
May 27, 2011 11:33:01 AM

in_core said:
i m also shocked...i have tried os many things and theres no solution...
is there any way to remove all my firefox extention and addons when uninstalling firefox....i might try that
but as i said i took that path many days ago but dosen not fix the problem


Did you try the software I have suggested you in 1st page?Please give a try,It may work,Don't fear this software,it is from the maker of Download Accelerator Plus(DAP) 'Speedbit'.I use it and fix the problem with my firefox 4,I was also not unable to change the home.

http://download.speedbit.com/RestoreBrowserSettings.zip
m
0
l
!