Sign in with
Sign up | Sign in
Your question

XP Peer-to-Peer Problem

Last response: in Networking
Share
February 9, 2004 8:45:19 PM

I'm having trouble getting a home network working using Windows XP. I'm posting in this folder because I believe the problem to be related to software, not hardware. We have three computers running Windows XP Home, each connected to a Linksys Wireless-G USB Network Adapter. We have established that the adapters can see each other, because we can get them to all resolve the same BSSID.

From any one computer, we can ping local host and the IP address assigned to that computer. Pinging any other computer results in a time-out.

The assigned workgroup always shows up, but we are sometimes denied access to it. There doesn't appear to be any rhyme or reason to when we are able to access the workgroup.

When we can access the workgroup, we can see other computers, but any attempt to access them is denied.

On all computers:
Windows XP Home SP1 has been installed
IP Address is static (169.254.254.x)
Subnet is 255.255.0.0
Each computer has been assigned the same workgroup name
Each computer has been assigned a different name
Computer Browser service is started
Workstation service is started
Server service is started
ICF and ICS are disabled
Norton Internet Firewall is installed, but disabled
Netbios is enabled for TCP/IP on the Wireless Adapter
The wireless adapter is operating in Ad-Hoc mode
WEP has been disabled

I have not tried to manage the master browser election, as I am unable to ping the other computers.

My next course of action will be to try manually clearing the ARP Cache, as suggested in a Microsoft Knowledge Base article. If that doesn't work, I'll borrow a wireless router with a DHCP server, to see if that helps resolve the issue.

Any suggestions would be greatly appreciated.

--
Allan

--
Allan

More about : peer peer problem

February 9, 2004 9:47:43 PM

Have you tried using a 'hosts' file?
<WinDir>\system32\drivers\etc\hosts (no file extension)
You'll see text as follows:
# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
# add in the lines that equate to your computers as in:
169.254.254.1 <Comp1 name>
169.254.254.2 <Comp2 name>
etc.
This should help to clear up the hosts not resolving to IPs issue. Now here is where my help gets sketchy :) 
I have never used XP home and I'm not overly familiar with the differences. I know this will fix this issue in XP Pro so you can take a look at it. This is to solve the 'workgroup' issue. For one when using a workgroup you should 'change the way users log onto windows' to do this go to Control Panel --> User Accounts --> click on 'change the way users log onto windows'
You may get a warning message about offline files being enabled click ok and disable offline files.
Then choose the 'Welcome' screen option. It's up to you to enable the fast user switching personally I like it.
You should be logging in with different users if not then no big deal. Make sure each box that you wish for a user to have access to has a local account with the exact same user/pass. I'm not sure if this is necessary since I have it on all of my computers anyway but you may wish to set up at least one share per machine. Right click the folder select Properties --> Sharing
You may (the first time) be asked if you'd like to run the wizard to share folders or to choose not to and that you understand the risks blah blah blah. You can do either I don't run the wizard.
Once done make sure the folder now has a check under 'Share this folder on the network' and 'Allow users to change my files' (unless you wish read only access)
You can leave it at this and try it but you may still have trouble. One last thing that I prefer is to go into Adminstrative Tools --> Local Security Settings --> choose the Local Policies\Security Options page --> Scroll down to the 'Network Access' settings --> change the 'Sharing and security model for local accounts' the default is 'Guest only local users authenticate as Guest' Change it to 'Classic local users authenticate as themselves'
I hope this helps you fix your problem.
February 9, 2004 11:22:29 PM

I added all of the computers to lmhosts, to no effect.

Unlike XP Professional, XP Home only allows simple network security, so you can't change the login screen and you can't set local security policies. In XP Home, users on remote hosts always authenticate as Guest, and that can't be changed.

I've made sure that each of the computers has file sharing enabled and has at least one shared directory. Again, that hasn't helped.

Thanks for the advice,

--
Allan
Related resources
February 10, 2004 2:06:42 PM

Bleh I was afraid of something like that. I'll load up an XP Home here at work when I get a chance. If I think of something else I'll post. Sorry couldn't help you with this so far.
Did you try lmhosts and hosts at least? Shouldn't make a difference I'm just grasping.
February 10, 2004 3:45:52 PM

does this mean you can't ping any of the peers via IP? Or you can't ping based on name resoultion, but IP ping works? I don't know which you mean...

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
February 11, 2004 1:33:16 AM

I've tried pinging the IP address, but it always times out.

--
Allan
February 11, 2004 3:52:02 AM

OK, all that stuff about the hosts file etc. is useless, you've got a much more basic problem. If you can't ping other IP's on the LAN, you're not communicating at all. No machine can ping any other? Did you check the lights on the NIC, hub, etc?

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
February 11, 2004 2:49:58 PM

I thought you could ping via IP but not hosts. Oh well. Have you considered a different IP scheme? The one you are using is for one Class B and two is in the range of the 'auto configure' IPs that Windows 2000 and XP will automatically asign itself if no DHCP server is found and DHCP is set. For home use I would suggest sticking to Class C addressing.
So try something like 192.168.0.x if you don't like that because it's so greatly used go for anything 192-221.x.x.1-255 try a subnet of 255.255.255.0.
February 11, 2004 3:55:50 PM

I know people don't like ICS, but it makes it much easier to have a machine acting as the gateway. It makes it an automatic DHCP server, so on the client machines you can check the basics like "am I getting an IP address".

I've also never liked Ad-hoc much, I'd start by borrowing that friend's router and then like you said, it can act as the DHCP server.
February 11, 2004 5:20:13 PM

Quote:
On all computers:
Windows XP Home SP1 has been installed
IP Address is static (169.254.254.x)
Subnet is 255.255.0.0

do you really mean "static" here - like you assigned the IP addresses manually? Or were these supposedly pulled from the ICS DHCP server? If the second, then you're not getting IP addresses from the DHCP server - those are the default Microsoft addresses when no DHCP server can be reached.

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
February 11, 2004 7:39:38 PM

It's a wireless lan operating as ad-hoc, so there's no hub. I'm relatively certain that the wireless adapters are talking to each other, as they all resolve the same Block SSID.

Also, the all of the computers show up in the network workgroup, so they are at least able to tell the other computers that they are there. It's just that when we try to access those computers that we get an error.

--
Allan
February 11, 2004 7:41:44 PM

I've tried the 192.168.0.x/255.255.255.0 IP range, as well as 169.254.254.x/255.255.0.0 range I mentioned earlier.

--
Allan
February 11, 2004 7:43:17 PM

so in ad-hoc mode there is not DHCP server? Everything is statically assigned? OK, just wondering why you chose the 169.254 octets?

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
February 11, 2004 7:45:34 PM

The IP addresses are really static. There is no DHCP server on the system. ICS is not running, since we are not trying to share an internet connection (each computer will dial-in for internet connectivity).

--
Allan
February 11, 2004 7:51:25 PM

<<OK, just wondering why you chose the 169.254 octets?>>

I didn't. I prefer 192.168.0.x for home networks, but I was trying to fix the network someone else set up, so I ran with their addresses initially. I changed them to 192.168.0.x at one point, but it didn't have any affect.

--
Allan
February 11, 2004 9:22:45 PM

sound like their addresses were fishy to begin with. I'd check all masks, etc. and get those bad boys pinging each other first. Without that, you've got nothing

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
!