Sign in with
Sign up | Sign in
Your question

Vista permissions

Last response: in Windows Vista
Share
April 25, 2010 12:03:27 AM

Hello,
I have been using Vista for some time now and have worked around the permissions issue until now. I have turned off the UAC facility because I am the only user and not networking. My vista was shop installed and I never really thought I had full control. Now when I download from the internet the File that is saved is saved under "adminstratorJohnadministrator" as the owner. This new administrator has just appeared and as I create subfolders they revert to that ownership as with downloaded files. I can take ownership under my log in name but it is becoming a pain. Has anyone any ideas that will enable me to create and download that will remain my ownership?? I really do not think the Permissions under Vista was worked out properly and I know that for some of you it appears to work so I would prefer you did not mention it :p ...
many thanks in anticipation

More about : vista permissions

April 25, 2010 1:10:40 AM

What folder names do you see in the C:\Users folder besides Public Folder?
m
0
l
April 25, 2010 1:21:52 AM

C:\Users "All Users" "Default" "Default User" "PCWinstallation" "Public" and "Release Engineer.MACROVISION"
6 folders in total and the last one is a new one.
m
0
l
Related resources
April 25, 2010 1:57:14 AM

When you logon (or in the User section of Control Panel, what user accounts do you have to choose from. Also the "PCWinstallation" folder, is this one of your user account? Is PCW particular to you or your business. I can find no reference to any applications by this name.
m
0
l
April 25, 2010 1:17:49 PM

Sorry I had to go to sleep.

PCWinstallation is the account PC World (shop that I bought PC from), installed Vista with.
I called my PC John.
administratorJohnadministrator which seems to take all ownership is a complete mystery to me.
I log on to PCWinstallation, which is only account I use and know about lol.

thanks again for your time.
m
0
l
April 25, 2010 1:24:25 PM

PCWinstallation is the only account showing under "user accounts",
there are 3 under "user accounts/ manage accounts" :-
1. PCWinstallation
2. ASP.NET Machine Account
3. Guest
m
0
l
April 26, 2010 5:27:19 AM

No that did not work,
info
1 was to go to Control panel, then Sys Maintenance and then adminstrative tools. That all opened up but not as it should have, I did not have the option of "Local Security Policies".

2 to type in "secpol.msc" in Vista Start Search. on doing this it opens internet explorer with the error message " Diognose connection problem", but as you see I am online as I did this!!

The options under item 1 above is Sys Maintenance shortcut from PCWinstallation, I think I have to access where the actual file is and maybe that is where I will find the "Local Security Policies".
Or can you suggest something else, I have tried M$ but they are not interested at all.
Thanks again for your time
m
0
l
April 26, 2010 5:30:10 AM

The only user on this is me under PCWinstallation, and I believe I am an administrator with all "permissions" lmao.... I bought this PC from new and it was shop installed with Vista so there should not be any other accounts on it...
m
0
l
April 26, 2010 1:01:01 PM

I am a little bit afraid to start the "hidden" administrator as it may indeed have a password and could possibly deny me any access to my PC as the installation was shop installed :( .
I guess what I would like is to log on as PCWinstallation as administrator, as I do now. But for some reason explorer seems to have this new "administratorJohnadministrator" in charge. sorry for my mumbling but it does help me to understand what is happening to my PC. Do you know if there is a "control user" for explorer and if so where it may be found.
I really do appreciate your time helping me thanks.
m
0
l
April 26, 2010 4:49:14 PM

Enabling the hidden administrator (which is really the main control account) of your Windows will not lock you out of your other profiles, but if you can get into it, it will allow you to give ownership of the disk and files to your PCWinstallation profile so that you will only have to use that account in the future. Then you can hide the main administrator account again. I believe that the administratorJohnadministrator account is the hidden administrator account. So you will have to access this account, and share ownership with your PCWinstaaltion account.

Let me know.
m
0
l
April 27, 2010 7:22:14 PM

I will attempt to do that , in the interim I went to the "computer management" throught the shortcut in admin tools, under "Disk Management" I found the C/ drive which is owned by the adminstratorjohnadministrator. I tried take ownership and was refused, so I added my PCWinstallation to the list and gave it all permissions. thought that would do it :( , no such luck, I have tried to install Nokia Ovi Suite, and got this error near the end of installation, " The installer has insufficient privleges to access this directory : C:\Program Files\Nokia\connectivity Cable Driver. The installation cannot continue. Log on as an administrator or contact your system administrator."
As far as I am aware I am an administrator under th PCWinstallation, so it should have worked. I also noted that the adminstratorjohnadministrator should actually be administrators(johnadministrator) the brackets make the name actually administrators which sounds more like a generic term M$ would use for the setting up of this system, does this make any sense to you?
thanks again
m
0
l
April 28, 2010 12:25:59 AM

Hi again,

I am puzzeled by your problem, but let's try this command line command and see if it makes a difference:

- Click start
- Type: command prompt
- Right-click command prompt when it appears
- Click Run As Administrator
- Type the following commands exactly, pressing enter after each line:

cd %userprofile%
icacls . /grant "%username%":( OI)(CI)(F) /T /C /L /Q


*Note: Actually type the commands as shown, do not substitute actual user names.
m
0
l
April 28, 2010 1:28:58 PM

The first command took me to

c:\users\PCWinstallation>

the second command was more difficult, I think there may be a minor error in it. These are my trials and results please note * denotes a space, and I have added a space between everything on here so no smiley faces showing :-

i c a c l s * . * / g r a n t " % u s e r n a m e % " : ( I ) ( C I ) ( F ) / T / C / L / Q "
RESULT : invalid parameters " / g r a n t P C W i n s t a l l a t i o n : ( I ) ( C I ) ( F ) / T / C / L / Q "

i c a c l s * . * / g r a n t " % username % " * : ( I ) ( C I ) ( F ) / T / C / L / Q "
RESULT : invalid parameters " : ( I ) ( C I ) ( F ) / T / C / L / Q "

i c a c l s * . * / g r a n t " % username % " * : * ( I ) ( C I ) ( F ) / T / C / L / Q "
RESULT : invalid parameters ":"

i c a c l s * . * / g r a n t " % u s e r n a m e % " * ( I ) ( C I ) ( F ) / T / C / L / Q "
RESULT : invalid parameters " ( I ) ( C I ) ( F ) / T / C / L / Q "

I also tried a few more options with similar results. I started the command prompt with "Run as Adminstrator"
I tried changing the brackets from parenthisis to "greater than" and "less than" symbols respectively with no joy.
I have also done a full system check for the file secpol.msc and cannot find it! I tried a system restore for windows only through Packard Bell setup, (its a PB comp so it was pre-installed) and got the error that the system "waS NOT READY"!!

m
0
l
April 29, 2010 11:55:12 AM

Sorry about that.

I copied and pasted the command while at work and didn't see the result. Some of the characters obviously were misinterpreted by the forum. As soon as i get back in my office, I will repost the command.

m
0
l
!