Sign in with
Sign up | Sign in
Your question

Chkdsk auto-runs on boot, but won't complete

Last response: in Windows XP
Share
November 5, 2009 6:59:51 PM

Today when booting up the pc, chkdsk autostarts (it usually doesn't..) but it hangs in the same place each time..

I'm running XP (updated), but not in English, so the quotes are translated as accuratly as I can:

It first confirms files (step 1 of 3) It then confirms index(?) (2 of 3)

It then says "Correcting error in index $I30 for the file 106330" (twice)

And then "sorting index $ I30 in file 106330"

Then it just stand like that (waited 3 hrs)

There is no sort of "work noise" or lights from the machine, just the fans.. I've tried restarting a few times, but no difference..

The only thing I did yesterday that might have had this kind of effect is installing Gimp, but I can't see how..

So, what is wrong and how do I fix it?
Is it possible to bypass the chkdsk function?

(Please bear in mind that as long as I can't bypass check disk, I can't get in to Windows, and I can't fiddle with the settings)

Thanks in advance!

November 5, 2009 11:36:17 PM

Use your OS disc to boot into the repair console.
At the command line type chkdsk /r
That will run a checkdisk and try to repair any errors on the disk.
Anonymous
August 11, 2010 7:07:53 PM

If anyone is reading this old thread for a clue, I suggest you wait before doing anything. I had the same problem with CHKDSK hanging in the same spot every time, but when I let it run for an hour it did it's thing and now the system is working fine.
Related resources
August 11, 2010 9:46:51 PM

If you can get it to start in safe mode,

You can turn off the boot time chkdsk.

Start>Run>CMD

Enter this:
CHKNTFS C׃ /X (and press enter).

Re-boot.

August 12, 2010 4:04:20 PM

Hi!

I have the exact same problem as you, only that I'm using Vista Home Premium, and it stops at "Correcting error in volume bit file" instead, and just stands there for 3 hours (and counting). I HAVE been able to get into Windows twice though (I should have fixed the problem then, I know, but i didn't...) but now I can't anymore. I got the OS with the computer when I bought it, so I have no OS disc. How can I get it to start in safe mode? And if I'm unable to do that, how do i fix the problem?
Please help.
August 12, 2010 4:43:54 PM



If you are truly desperate,

Boot computer with the XP disk.

One of the screens that will show allows starting in the recovery console, start recovery console.

Enter this:
attrib C:\windows\system32\autocheck.exe -r -h -s

If successful, next enter this: ren C:\windows\system32\autocheck.exe autocheck.old

enter: Exit

Re-start Windows. A benign error will appear as it is loading that will say autocheck.exe could not be found, skipping autocheck.

Windows will continue to load and run, unless the drive has a persistent error.

This workaround only works once as windows will restore the missing autocheck.exe and if needed, you'll need to do the rename thing all over again.

When you have windows running, turn off autocheck as I described above.


!