Sign in with
Sign up | Sign in
Your question

No more available com ports...

Last response: in Windows Vista
Share
April 28, 2010 12:15:31 AM

Hello
I am facing this problem. I am trying to set up a TM-T88IV Epson Thermal Printer under Windows Vista SP1. I have downloaded most updates, even those which are only recommended but not important.

When I try to install the driver I downloaded from epson website, I get to a screen in which I have to choose among the possible connections (USB, COM, Ethernet,...). Since this thermal printer is linked to the computer through the COM port, I select COM as connection.

The problem comes up after selecting COM because the installer program shows up a window with a message like "No more available COM ports..."

After some research I thought this might have to do with COM ports being busy by other devices. Nonetheless I do not use a serial (COM) mouse but a USB one.
Apparently, there are only two external COM ports on the back of this HP desktop computer and just one of them is used with this printer, the other is free. Anyways, I read somewhere that serial COM ports sometimes should be freed up by disabling them at BIOS level. I looked this COM port in all the BIOS options, the advance tab included and there is no COM port option at the bios displayed for this computer. Well, this might be because new computers do not show their COM ports in the BIOS.


The problem is that this printer was working so far but something happened to windows Vista which did not let it boot anymore. Therefore I had to restore windows vista with the typical HP restore software.

After doing that the printer does not work.
If I go to control panel->printers then I do not even see the printer because I could not finish the installation process, as I told you, I got stuck with the step of choosing the connection (COM).

Other approach I tried was buying a USB to serial cable and trying to set usb as connection type in the corresponding step of the install software. It seems that this did install the printer because control panel->printers showed the printer. However, it showed it as no connected even when it is plugged.

Eventually, I tried one more thing with this USB to serial converting cable: installing the special software that epson put in their website to make this TM-T88IV thermal printer work under a USB interface. But, this did not work either because the printer shows up in controlpanel->printers as no connected.

Moreover, hopefully the printer is not damaged since it has been protected from high currents with one of this typical multiple outlet extension cord specifically designed for this purpose.

I found USB ports, SATA, and something more but nothing about COM ports. Moreover, I read somewhere that new motherboards might not mention COM ports in the BIOS.
I used the HP restore funtction which is loaded at boot time without any kind of CDROM. I just restored the computer to the manufacturer state. But I did installed neither windows nor chipset drivers, I thought that might be done just by restoring the computer to the original settings.

I did not see any COM port line in the device manager. Moreover, the only time when I saw a line with a COM port in the device manager was when I installed this 3,5MB driver from Epson which apparently is useful to use this printer through a USB port. The description give for this small driver in the Epson's website is:"TM Virtual Port Driver
This driver is a serial/parallel-USB conversion driver to make an EPSON TM/BA/EU printer and DM-D Customer display connected via USB accessible from a POS application through virtual COM/LPT ports."


The problem is that this driver I saw might just be a simulated COM port. Anyways, I tested the printer with the USB-SERIAL cable and this driver installed and it did not work either as I said in my first post.

What I did see in the device manager is:
- one line called something like "PCI serial...."
- and two lines called somthing like "indefined...". If I right click properties on them, then it seems they are not properly configured. I just can see the brand epson somewhere in their properties. Epson is the brand of the thermal printer but that does not prove anything.

For the time being, I cannot think of any other idea to make this printer work.

I greatly appreciate any kind of suggestions to solve this problem which is driving me nuts.

Thanks a lot in advance.
Reply With Quote

More about : ports

April 28, 2010 12:56:40 AM

A "PCI Serial" Device is likely your COM port without a driver installed. This is how dial-up modems used to appear in the device manager before the driver was installed (hardware modems had COM ports built in). You say that your computer has two COM ports. Are they built into the motherboard, or are they on an expansion card?
m
0
l
April 28, 2010 1:05:21 AM

This is an HP desktop pc which is pretty new. I do not know whether this external serial ports are built in the motherboard or in a expansion card because I have not opened the case yet.
m
0
l
Related resources
April 28, 2010 1:24:39 AM

Just tell me the model # of the HP computer and I will check the specs, but if you decide to open it up make sure you unplug the A/C power cord first.
m
0
l
April 28, 2010 1:27:20 AM

Thanks for the help, greatly appreciated.
I will check the model and post it here when I have it, I hope to have it soon. For the time being, I am curious, what help might it bring knowing the model of the HP computer?

Thanks
m
0
l
April 28, 2010 1:30:40 AM

If the serial ports are on an add-on adapter, then look for the brand name and model number of the card. It should be silk-screened on there somewhere. I know Lavasoft makes add-on serial cards, as an example.
m
0
l
April 28, 2010 1:59:13 AM

So, there're two choices:
- com ports are installed in expansion card=> download expansion card's drivers
- com ports are built in motherboard=> download and install motherboard's drivers

Before testing one of the previous two choices, my only concern for the time being, I hope the problem does not have to do with bios not being set up properly.
Thanks
m
0
l
April 28, 2010 2:12:12 AM

I don't think your BIOS is a problem. Unless the event that caused you to run the System Recovery effected the BIOS. Why did you reload?

The reload would not likely include the third party drivers for an expansion card.

The other possibility (but I would think that the COM ports should be viewable in device manager) is that the older printer requires COM Port settings as they traditionally were set such as COM2 on IRQ3 or COM1 on IRQ4. XP and Vista do not always use the original IRQ settings, which may adversly effect the communication to the printer. A computer recovery would wipe out customizations such as IRQ assignments.
m
0
l
April 28, 2010 7:22:49 AM

As I said in my first post,
"The problem is that this printer was working so far but something happened to windows Vista which did not let it boot anymore. Therefore I had to restore windows vista with the typical HP restore software.
", that is to say, I restored the system because windows vista did not boot anymore. Anyways, I thought Bios settings were only could only be updated through BIOS. I thoght this settings could not be updated by software like the one used to restore the system to its factory state, that is to say, to the state with just Windows Vista and the needed drivers installed because that is basically what I did.

If by "older printer" you mean the OKI printer, well, this printer is OKI B430dn Model No. N22115B. It is linked to the computer through USB port so, why it should require any special COM port settings?

For now, I will look for the motherboard brand and model to check whether it has com ports built in in its specs.
I will try "download expansion card's drivers" in case com ports are in expansion card or download and install motherboard's drivers in case they are built in the motherboard. The only doubt is that there might be com ports on both expansion card and motherboard.

I will keep you updated.
Thanks for the help.
m
0
l
April 28, 2010 9:57:18 AM

According to siw the motherboard model is
Manufacturer MSI
MODEL 2A78h
version 1.0
chipset vendor intel corporation
chipset model P35/G33 (Bearlake) Processor to I/O Controller
CPU Intel Core 2 Duo
Cpu Socket LGA775 [Socket 775]
Max CPU Speed 4000 MHz

Any idea?
Thanks
m
0
l
April 28, 2010 10:04:46 AM

This is what I really see:
I see no com port in device manager but I see:
? Unknown device
? Unknown device
?PCI serial port
The ? sign might indicate this devices are not properly configured.
Any idea?

Thanks
m
0
l
April 28, 2010 10:43:42 AM

And this is the PC:
Hewlett-Packard HP Compaq dx2420 Microtower
Motherboard is MSI 2A78H
Any idea to make COM ports work?
For the time being neither device manager nor SIW display any COM port.

Any idea to enable a COM port. I do not see any COM PORT option in the BIOS either.
Any idea?
Thanks a lot.
m
0
l
April 28, 2010 8:24:21 PM

Eventually,
I got to see the COM ports in the device manager. This is what I did to be able to see them. The two COM ports are not in the motherbaord but in a SUNIX expansion PCI card with two COM ports. So I asked SINUX for the drivers, downloaded them and installed them. Then I installed the EPSON TM-T88IV thermal printer with the printer unplugged. In the installation process there is a step where you have to choose among a list of possible connections: USB, serial, ethernet,... I chose serial and then it shows up a window with the two COM ports that I see in the device manager: COM3 and COM4 so that I select one of them to install the printer with it. I do not know why but I do not see COM1 and COM2. Anyways there are only two physical COM ports on this PCI card so I guess I should not bother with the name of the COM ports as long as I see two COM ports in the device manager.
Anyways,after selecting COM3 as the port that the printer is going to use, the installation process of the printer's drivers finishes. Then I turn on the printer and plug it to the computer. Then I still see the printer in the controlpanel->printers as no available instead of as ready. So what I try now is this: I reboot the computer. But this does not fix the problem either. So I change the cable to the other COM port. This does not work either. Then I reboot the computer. But this does not work either. Then I decide to install the printer's drivers also on the second COM port available, that is to say, COM4. Then repeat the same steps as I just detailed but it does not work either. Basically the printer should work now no matter the COM port I plugged it of the two available COM ports because the printer's drivers are installed on both COM ports just in case that worked.

Anyways, now I do not know what I can do to make this printer work. It was working until two days ago, but now it does not get the ready state in control panel->printers and instead it stays as not available for both COM ports.

Any idea to make this EPSON thermal printer TM-T88IV work?

Thanks in advance
m
0
l
April 28, 2010 11:06:59 PM

Ok... progress. We have solved your COM ports missing by getting you to determine whether or not they were onboard or not. Finding that the COM ports were on an add-in card allowed you to download the driver that was lost during your reinstall. What we have to do now is configure those COM ports to match what the printer expects, with I think is output from COM1 or COM2 on standard IRQ assignments as I stated earlier. Here is a link to a manual for this brand of card. It may not be the exact model because you did not state the model. Use these instructions to configure one of your ports to work on COM1.

Let me know how you make out.

http://docs.google.com/viewer?a=v&q=cache:R-jILX4QXOIJ:...
m
0
l
April 28, 2010 11:27:33 PM

the model of this card is SUNIX SER4037T. I did not find the drivers for SER4037T in the SUNIX website but I found them for SER4037x where x are letters different from T. So I asked SUNIX support by email and they sent me the drivers.
m
0
l
April 29, 2010 1:26:02 AM

I have a new problem besides this epson printer. I do not know why but may be because of installing the chipset drivers for my motherboard to try to solve the problem of the com ports, now the cd rom does not read the cds. It is not like when the cdrom lens is dirty because now when I put a cd in the tray and close the tray, then the computer quickly displays a message which says that a cd should be placed on the tray and opens the trray at the same time. Hopefully this might get solved easily, but I do not know why this is happening. I do see the cdrom in the device manager though.
Any idea also about this problem?
Thanks a lot.

m
0
l
April 29, 2010 1:54:14 PM

Hello eventually I set up successfully the printer because now I can print for example from notepad with this epson TM-T88IV. All I had to do was use the same settings in both the com3 port in the device manager and during the printer's drivers installation process, settings such as baud speed (9600) and flow control (hardware) for both of them.

The question now is that the printer does not get to work successfully with a POS software called tpvsol.
The problem is that the printer is selected in the configuration menu of this program. As far as tpvsol manuals says, it seems there are two choices to set up the printer with this tpv:
either select the epson printer from the list, as I did (it did not work)
or select just a printing port. By default it writes LPT1.DOS but my printer is in COM3 port. Moreover, if using this second choice I should fill the 4 fields corresponding to the opening of the cash drawer, for red color, for black color and for automatic cutting of the ticket. By default there are some numbers filled as well for these four fields and they are like these in the same order I mentioned their meaning:
27 112 48
27 114 49
27 114 48
27 105

According to the POS software manual, these codes should usually be available on the printer's manual but I have not found them at there.

Any idea to make this printer work with this POS software?

Thanks a lot.


m
0
l
April 29, 2010 10:13:24 PM

Try this command at the command prompt window and then try your printer. If it works, you can create a batch file to run the command each time you start your computer:

mode LPT1: = COM3

m
0
l
April 30, 2010 8:37:01 AM

Thanks a lot to all of you, the printer printer is already set up successfully with the POS software. I was not setting up it right untill I call the POS software support number.
Thanks again. Moreove, I called to epson to get the codes for the drawer and the automatic cut of the ticket by the printer. These codes are not provided in the printer manual as ar as the epson support people told me on the phone.
Thanks again.
m
0
l
!