Sign in with
Sign up | Sign in
Your question

Computer recognizing USB Mass storage device but not shown through com

Last response: in Windows Vista
Share
May 19, 2010 12:52:30 PM

I’m using an IDE to USB cable to see an external hard drive. My computer recognizes the USB mass storage device as seen in the Device Manager but I can’t see it on my computer.
May 19, 2010 10:43:54 PM

Quote:
If you can see it under Device Manager as working and not in My Computer at all you will need to undo any partition and then do a quick format to get it to work. You should also notice the LED not flashing before you do this. I JUST did this to two different HD's. One was a Passport and the other a My Book.

I right clicked on My Computer, clicked on Manage, then on the left you will see Disk Management. Click on that. You should see ALL of your HD's as well as your Burners. Right click on your "broken" HD and delete volume. It should go Unallocated. Right click on Drive again and format with a quick format since you have no data on it anymore. It should work. Good luck!

May 20, 2010 9:03:56 PM




Thanks for the info. I need to keep the data. I want to run a virus scan on the HD and then transfer the data to an external HD. All the jumpers are correct. The HD works fine in the intended computer, but it's not allowing me to see it in my computer.

What else can I do?
Related resources
January 31, 2011 1:36:54 AM

I realize this is an old thread but i am dealing with almost exactly the same situation only mine is with a smaller 1.8" hdd connecting to a usb/ZIF connector. It shows up when I plug it in and automatically installs it but just like yours its not appearing in my computer and I also need to keep the data on it. Thanks in advance if you can let me know what you ended up doing.

November 10, 2012 11:38:48 AM

jjphipps said:
I’m using an IDE to USB cable to see an external hard drive. My computer recognizes the USB mass storage device as seen in the Device Manager but I can’t see it on my computer.


Hi, I am a computer engineer from Pakistan, currently in the UK. The possible cause of your problem is a Bios password protected hard-drive. You need to place the HDD into the original system and from the bios boot process on start up disable the password in the bios. I don't know if this will work if you put the HDD into another computer as an internal HDD it may work, I've never tried it though. Ideally you need to place it into the original pc on which the bios password was activated. At the moment I personally don't know of any software which can disable a bios password protected external HDD. You might want to Google that.

P.S, please let me know if my solution worked for you.
!