Window Vista and memory

I have Windows Vista, 64 bit, (fully updated.)In computer properties it read the full 4GB of memory but BIOS and dxdiag only read 2GB any ideas?
The Motherboard is stock in an Acer Aspire E380 (model number ASE380-UD480A)
6 answers Last reply
More about window vista memory
  1. BIOS (or motherboard... unsure which) = MCP61M-AM-6A61KE11C-00
    OS = Windows Vista SP2 64 Bit
    RAM = 4GB
    problem = simple... my BIOS, Windows Task Manager, and dxdiag are registering 2GB of RAM while my comp properties state 4.00 GB
    solutions tried... reseating RAM and ensuring my comp and drivers are up to date.
    hopefully that helps a little bit
  2. If the bios reads only 2, then there is a hardware/bios problem of some sort. Its not the operating system.
  3. Is there a way for me to upgrade/fix my BIOS? I went to www.acer.com and selected my model and downloaded the upgrade, but when I run it I get a message that states "OnBoard BIOS not Award BIOS" and when I access my BIOS settings it says "Phoenix - Award Workstation BIOS CMOS Setup Utility." I am so flarkin confused right now it isn't even funny. Main reason I am asking for help on this site is I cannot afford to take it in for repairs
  4. What was the name of the file you downloaded?
  5. BIOS_R01-C0
  6. ok i have 2 bios downloaded and neither of them work BIOS_R01-C0 and R01-B4
    finally figured out all the coded numbers lol
    Motherboard = MCP61M-AM
    BIOS = 6A61KE11C-00
    (apparently both are from ECS even though I have an Acer Aspire E380)
    and my Windows Vista IS indeed x64
Ask a new question

Read More

Windows Vista Memory