Sign in with
Sign up | Sign in
Your question

Cannot get printer to hook up wirelessly

Last response: in Wireless Networking
Share
September 1, 2008 1:25:01 AM

OK, I have a TP-LINK TL-WR541G router and a Brother MFC885CW printer w/ WinXP w/SP2.
Now, the printer works great via USB, but I cannot get it recognized via the brother SW package either wired or wireless.
I have turned off my firewall (NIS2008) as requested in the instructions (yeah, I know, nobody reads the darn manuals, but I was desperate) and want to know: Do I need to turn off the router firewall too?
My daughter has no prob connecting WL w/ her notebook and would like to print too.....She has school starting soon and I would love to get this resolved.

Thanks to those who know....
September 1, 2008 8:29:06 AM

6 views and no ideas???C'mon people, I REALLY need your help on this one....
Anonymous
December 16, 2008 10:48:56 AM

Maybe you've already gotten your answer, but I was having the same problem. I kept re-running the setup wizard at the machine itself and it would just hang when trying to establish a connection. What I did was reset the machine to the factory settings (via the menu on the machine itself) and then re-ran the setup wizard. It worked. SO I'm guessing that because I had changed the router from WEP to WPA and had attempted to connect to the router with WEP it maintained that entry in memory and wouldn't let me overwrite it with a WPA entry.

Hope this helps.
October 18, 2009 6:21:45 PM

Sorry for the horribly late update. I fixed it about 2 months ago. I needed a SHORTER passkey. WOW, that was tough...
But thanks to all for your help on this and many other matters.
!