How do I fix the drive assignment in Win XP?

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I installed an external hard drive (with USB connection), which Windows XP
assigned as drive F: Then, when I re-connected my printer, XP assigned it to
drive F:, and re-assigned the hard drive to G: !! How do I make Win XP
recognise the hard drive as F: and, more important, stop it from changing?
As I have drive mappings to F: in various applications, it's very
inconvenient if it keeps changing !!

Any ideas or suggestions welcome, Richard
1 answer Last reply
More about drive assignment
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    "rfpcarpenter" <rfpcarpenter@discussions.microsoft.com> wrote in message
    news:AD49E625-A458-4106-BACF-1488B9A94739@microsoft.com...
    > I installed an external hard drive (with USB connection), which Windows XP
    > assigned as drive F: Then, when I re-connected my printer, XP assigned it
    to
    > drive F:, and re-assigned the hard drive to G: !!

    Try removing the external drive and connecting the printer, then change the
    printers drive letter . See "Assign, change, or remove a drive letter" in
    Help and Support for instructions. Try setting it to something like P: .
    Don't use Z: Y: X; etc because they are normally used by mapped network
    drives.

    Then reboot to confirm the printer is still P:

    Then power down and reconnect the USB drive, reboot and see what it's
    allocated.

    I set all removable media drives (eg CDR, DVD) to L: M: N: etc so that my
    hard drives are C: and D: and my USB drive is always E:
Ask a new question

Read More

Windows XP External Hard Drive