Sign in with
Sign up | Sign in
Your question

nForce4 Ethernet Problems/Bug

Last response: in Motherboards
Share
July 5, 2007 8:20:10 PM

I have a problem. I have a LanParty NF4 Ultra Motherboard with 2 LAN Ports. One nForce Ethernet and another Marvel LAN (PCI). A while ago, I had a problem where the Ethernet port could not establish a connection. It would say acquiring address... then say "Disconnected". It would go on and off like that. (The Light on the LAN Port would flash on and and off as well. Also on the router (Linksys WRT54G), the light that I'm connected to would flash as well). So I installed the Marvel LAN drivers, and using this worked just fine. I switched out the router to no effect. So obviously it wasn't the router.
To fix the problem the first time, I just reformatted.

This problem hasn't happened again for almost a year. I reformatted like 2 weeks ago. Still no problem, then my computer went into Standby earlier yesterday(think one of my parents did it). After that, about 3 hours after use of the computer, I lose connection and it starts to do it again.

I just installed the Marvell LAN Drivers for now because I don't plan on reformatting so soon.

I've tried to research the problem, but I'm using the wrong set of keywords I assume and can't find anything about this problem. Another one of my friends had the same problem as me before. He got a new modem, and it worked fine after words, he was using nForce 4 as well.

So, does anyone know of this problem and knows how to fix it? Or can do a better job at researching the problem?
Or, even as a third option, is there a way to reinstall windows over top of the old windows without having to format? I doubt there is unless you made an OS partition, which I don't. I usually just backup my stuff onto one of my 250gb storage drives. But its such a pain to backup all my settings, then put them all back after reformat. *sigh*

Any help is greatly appreciated.
July 5, 2007 9:29:13 PM

1. Did you try just reinstalling the driver for the nVidia ethernet port?

2. Are you using the most up-to-date nVidia diver, the most-up-to-date mobo manufacturer's driver, or an older driver? If you're not already using the latest forceware drivers go to nvidia.com and get it and update all of your chipset drivers. If that doesn't work think about using older drivers from nVidia or the mobo maker.

3. Why do you care? You obviously only use one ethernet port if you never even installed the drivers for the marvell NIC. Just disable the nVidia one and use the other one?

I would guess that a round of driver updates is in order if hibernate is screwing up your system.
July 5, 2007 10:08:30 PM

I had a similar problem in Vista with my onboard NF4 ethernet port. The computer would enter an S3 sleep-state and awake with "limited or no connectivity." Right-clicking the taskbar icon and selecting "Repair" would fix it every time.

The problem went away when I ditched the nForce driver I was installing from nVidia's website and used the certified driver from Microsoft Windows Update. No problems since.
July 5, 2007 10:32:57 PM

Quote:


The problem went away when I ditched the nForce driver I was installing from nVidia's website and used the certified driver from Microsoft Windows Update. No problems since.


That's a good suggestion too.
July 6, 2007 2:15:50 AM

@ Flasher702..
1 - Yes i did, several times.
2 - Im using the most current up-to-date nVidia driver.
3 - The marvel PCI is a bit slower/laggier than the ethernet itself. Uses more CPU when Im doing alot of things online at once.

Sciberpunkt - Does not work when i try it. Where can i get the microsoft one? I searched the site but cant find anything that I would consider a network/Ethernet driver. Point me in the right direction please :D  thanks.
July 7, 2007 8:23:19 PM

try going to "drivers guide" If nothing else, it may lead you down the wright road.
July 7, 2007 8:49:50 PM

When you do get this fixed, go into BIOS and XP and kill all suspend/hibernate settings. IMO MS never got that stuff right. I just turn off the monitor and HHDs, never suspend or hibernate.
July 10, 2007 8:32:11 PM

Well... It seems Its fixed. I flashed my router's firmware with the latest DD-WRT Version (v23 SP2). Getting rid of the default firmware from linksys(I had upgraded to a newer version about a year or so ago, before the original problems). Re-installed the nForce Ethernet Drivers for my motherboard. And its not doing it anymore.

I'm thinking that I had some sort of WakeOnLan or LAN Feature that was linked with hibernate, so when it came out of hibernate/Suspend, the LAN got fucked up. And putting a new firmware, the settings on the computer saw a new router or something?

I really have no idea to be honest, lmao.

Ill probably end up formatting anyway since i have like 20 different drives for Network controllers right now. But who knows, now that I think about it, I didnt have the problems before I upgraded the linksys firmware, so maybe it was the certain firmware of linksys and had a problem with my board/network controller only?
!