Sign in with
Sign up | Sign in
Your question

unable to transfer files to pen drive

Last response: in Storage
Share
July 16, 2007 10:14:07 AM

hi
i am getting a lot of problems with a 1GB kingston pen drive i just bought.i cannot transfer files to the pen drive ,most of the time
i get the following error message :
error copying file or folder

cannot copy "filename" : cannot find the specified file.

make sure you specify the correct path and file name

If by chance i successfully transferred a file ,next time i reconnect my pen drive ,it's empty and all the files have disappeared.tried to transfer a 450mb file to the pen drive and in the process,it stops and it tells me that the destination drive cannot be found .


My second issue i often gets the follwoing message when i try to open the pen drive :
The disk in drive J is not formatted.
Do you want to format it now?

when i click on yes , i get the following message:

windows was unable to complete the format.

this drive cannot be formatted.

This time also if i successfully formatted the pen drive ,i get the problems
mentionned above.

here's the specs concerning my mobo :
http://www.qdigrp.com/qdisite/eng/products/K7B.htm

i' m also running windows xp ( no service pack )

here's the specs concerning the pen drive :

http://www.kingston.com/flash/datatraveler.asp

thanks in advance
a b G Storage
July 16, 2007 3:33:23 PM

Return it and get a functioning drive.
If you cant format it reliably, then either your USB plug is fried, or the device is.
July 16, 2007 5:56:09 PM

You REALLY should at least load service pack 1 :o  XP with no sevice pack is not supported by a lot of modern software. You are also not using latest USB driver. VIA did not have the best name for USB support at that time. Have you loaded the drivers that came with the motherboard?, have you tried latest update from VIA?

Mike.
Related resources
a b G Storage
July 16, 2007 7:31:58 PM

Ah good catch Mike99. Didn't see the no service pack.

Ya VIA has updated USB drivers (2.0 included). Windows XP SP 0 is terrible.
July 17, 2007 4:17:40 AM

ok .can u guide me on how to update the usb drivers from VIA ?
i am a complete noob...
any other alternative apart from installing sp1 !
July 17, 2007 5:14:27 AM

gundja2 said:

any other alternative apart from installing sp1 !


Install SP2 :sarcastic: 
July 17, 2007 5:14:43 AM

gundja2 said:
ok .can u guide me on how to update the usb drivers from VIA ?
i am a complete noob...
any other alternative apart from installing sp1 !


Installing sp2?
July 17, 2007 5:33:18 AM

Gh0stDrag0n said:
Install SP2 :sarcastic: 


turboflame said:
Installing sp2?


:bounce:  Ha! beat you by a whole 16 seconds. :kaola: 


July 18, 2007 5:50:12 AM

ok i finally installed service pack 2 and the problems are still the same.
what can i do now ?
July 18, 2007 10:11:29 AM

Test pen on another system. If it fails, is pen! If it works, get PCI USB2 adapter card, it will work faster as well.

Mike.
July 18, 2007 10:34:32 AM

hey i finally found the culprit , today i install a pci usb 2.0 card and now my pen drive is working fine.the main problem was that the usb drive was not compatible to usb1.1 despite kingston mentionned it was
also 1.1 compliant.thanks for all help
a b G Storage
August 16, 2007 8:56:37 PM

All USB 2.0 equipment is required to be 1.1. compatible and all USB ports are required to support USB 1.1 as well.
Anonymous
a b G Storage
June 21, 2009 9:21:37 AM

Yes, there is hardware issues these days as most of the hardware companies compete amongst them just for more profit and we are culprits that we r idea less but don't worry we will be what we are...
So, about these pendrive, usb 2.0 is latest and if you're usb port is not 2.0 then there is nothing to deal with but to upgrade to 2.0. or else you have so much to do.

1. Use latest antivirus and scan your PC thoroughly and your pendrive too. If you found a single virus in you PC or in the Pendrive after deleting the virus, you delete manually the file "autorun.inf" from all drive and restart PC.

2. Check the pendrive which filesystem does it uses. Mainly small GBs use FAT system or else you can use NTFS. You know what I meant. Convert the filesystem to one after another while checking if transfer works or detects. Use DOS to convert the filesystem.

I hope this will work.... :hello: 
!