Sign in with
Sign up | Sign in
Your question
Closed

Display driver has stopped working

Last response: in Apps General Discussion
Share
November 26, 2011 10:31:01 PM

Hey guys i have a quick question...
everytime i play a demanding game my CCC stops working and i get this message that says "Your display driver has stopped working". I've monitored me temps and my cards (6770 crossfire config) have never gone above 60c so those are reasonable temps. I have also disabled CrossfireX and it still happens (. PLS RESPOND QUICKLY I CANT TAKE IT ANYMORE! **edit I dont want to have to reinstall windows and my video card drivers are up to date 11.11 as of 11/26/11, thanks
a b \ Driver
November 27, 2011 1:16:04 AM

Whats your PSU?
Score
0
November 27, 2011 3:20:50 PM

are you using beta version or complete
Score
0
Related resources
December 7, 2011 3:54:45 PM

i have a 750w psu and im not using the beta version
Score
0
a b \ Driver
December 22, 2011 11:40:56 AM

I think it's the ATI drivers in general. I run into this issue at least once a month when playing borderlands. At that time, my video freezes for abot 20 seconds, then goes blank for a second or two, then resumes just fine. Later when I check the event log it says the display driver stopped working and has been restarted.

I'm not sure why yours doesn't restart on it own though. It may have something to do with your x-fire setup.
Score
0
December 30, 2011 1:01:15 AM

I have this same issue with a Sapphire 6570 1gb ddr3 card. It happens when I'm playing Minecraft and Skyrim. Never happens with league of legends still very frustrating. I have downloaded my CCC drivers straight from AMD and I'm running 11.12 (the most current as of this post). I have re installed Windows (W7 32bit) and still get the same issue. all my drivers are up to date. Any help or suggestions are greatly appreciated.
Score
0
December 30, 2011 4:20:25 PM

Hawkeye22 said:
I think it's the ATI drivers in general. I run into this issue at least once a month when playing borderlands. At that time, my video freezes for abot 20 seconds, then goes blank for a second or two, then resumes just fine. Later when I check the event log it says the display driver stopped working and has been restarted.

I'm not sure why yours doesn't restart on it own though. It may have something to do with your x-fire setup.


Alright I'll be sure to play with that a bit thanks!
Score
0
December 30, 2011 4:21:19 PM

truegenius said:
are you using beta version or complete


I was running the complete version at the time but even on 11.12 I get the same issue :S
Score
0
January 6, 2012 1:32:22 AM

Ive come to the conclusion that all software put under extreme
'load" will fail overtime....
Score
0

Best solution

January 7, 2012 8:14:26 PM

ati drivers are not stable, and beta drivers are highly unstable

this happened to me too on my hd6770

to resolve this i reninstalled the window

you can try to restore window to previous state (when it was working correctly), you can find it in accessories in start menu

or try to uninstall and then renstall drivers
use driver cleaner to clean traces of previous drivers before reinstaling them
and do not use beta drivers
Share
January 16, 2012 7:46:36 PM

truegenius said:
ati drivers are not stable, and beta drivers are highly unstable

this happened to me too on my hd6770

to resolve this i reninstalled the window

you can try to restore window to previous state (when it was working correctly), you can find it in accessories in start menu

or try to uninstall and then renstall drivers
use driver cleaner to clean traces of previous drivers before reinstaling them
and do not use beta drivers



alright thanks a lot maybe i will switch companies try out Nvidia again
Score
0
January 16, 2012 7:46:48 PM

Best answer selected by toepickles.
Score
0
a b \ Driver
January 16, 2012 8:09:21 PM

This topic has been closed by Nikorr.
Score
0
!