Sign in with
Sign up | Sign in
Your question

Vista laptop keyboard types wrong characters

Last response: in Windows Vista
Share
Anonymous
a b D Laptop
September 2, 2010 12:01:08 PM

Hello, how can I fix my laptop from typing wrong characters?
a b D Laptop
September 2, 2010 12:04:25 PM

Check you have it set up for the right keyboard map under Regional Settings?

Alternatively, give a few more details. What characters is it typing wrongly? It could be something as simple as having the NumLock on if it is typing numbers instead of some characters.
m
0
l
September 2, 2010 10:27:01 PM

1. Examine your keyboard for any build-up of dust, dirt, liquids or other particles that could be causing the keys to type the wrong characters. Allow any loose dirt to fall out by inverting and shaking the keyboard lightly.

2. Plug your keyboard into another computer. If the keyboard works, then the port on your original computer may not be working.

3. Confirm that your keyboard is set to the English language. Go to your control panel and click on the "Regional and Language Options" icon. If the setting appears to be in a foreign language, change it to English/U.S.

4. Check if your number lock key is on. If so, depress the key to disengage it.

5. Run a character key test by using the Microsoft Keyboard Diagnostics (MSKEY) program. While in the MSKEY program, hit several keys to make certain that they are the same keys that are identified in the MSKEY window.

I hope this helps!

Brett M,
Windows Outreach Team
m
0
l
!