Optiarc 7170 driver/decoder?

I just bought an OptiArc 7170A DVD player for my XP. It plays music properly, and I can burn CDs, but when I try to play a DVD I get a message about not having the right "decoder".

I did some searching but did not find a good source for this "decoder". Can someone tell me where I can find one, and what it is? And why the devil it's so hard to find? TNX.
11 answers Last reply
More about optiarc 7170 driver decoder
  1. I bought the same drive, and it wont work in Vista 64. I havent tried to burn anything though. It wouldnt install on it, and when I used another drive to install, and then put the drive back in, it works, but often crashes the pc.

    when I tried to install it in Vista, it said please locate drivers for it, which dont exist. firmware upgrades havent worked, it always says it cant find the drive.

    I think mine is faulty, but you never know. either way, hopefully it will be the last time I buy something from sony nec.
  2. You need dvd playback software, like Intervideo or Powerdvd. they contain codec's your pc needs to playback dvd's
  3. mr_curious said:
    I just bought an OptiArc 7170A DVD player for my XP. It plays music properly, and I can burn CDs, but when I try to play a DVD I get a message about not having the right "decoder".

    I did some searching but did not find a good source for this "decoder". Can someone tell me where I can find one, and what it is? And why the devil it's so hard to find? TNX.


    Anonymous said:
    I bought the same drive, and it wont work in Vista 64. I havent tried to burn anything though. It wouldnt install on it, and when I used another drive to install, and then put the drive back in, it works, but often crashes the pc.

    when I tried to install it in Vista, it said please locate drivers for it, which dont exist. firmware upgrades havent worked, it always says it cant find the drive.

    I think mine is faulty, but you never know. either way, hopefully it will be the last time I buy something from sony nec.



    You need to update the firmware. Its an easy thing to do once you find the proper program to flash the drive and then install new firmware files. Make sure you do a backup before flashing.

    Try looking at http://www.cdfreaks.com

    or do a google search. I had similar headaches w/ my optiarc drive that were cured with updated firmware.
  4. Quote:
    but when I try to play a DVD I get a message about not having the right "decoder".


    its not the hardware... you dont have an mpeg2 decoder installed on your system.. like others said install powerdvd or intervideo... a lot of dvds come with this software on the disk.

    OR you can choose the better option and install the free video player... VLC (it plays EVERYTHING save for real media)

    www.Videolan.org
  5. I have a similar problem with the same unit. I can play music CDs , and playback DVDs with PowerDVD, but when I play DVDs using Windows Media Player , I get the video but no sound .
    Any help would be appreciated .
  6. I'm also having similar problems. Specifically, I have an Optiar AD-7170-0B. I had noticed no problems until I tried to play a DVD. It told me I did not have a decoder loaded. I re-installed Intervideo, but can get nothing to play. It WILL however read the disc enough to say what is on the disc, but it just won't play. I've already upgraded to firmware 1.2, but have seen no difference. Any thoughts?
  7. It was a while ago so I'm having a problem recalling. If you have another (CD) drive, does that give you sound? My recollection was that in fact, my problem might have had something to do with a bad installation or setting re sound. I also recall quite clearly that I was not able to find a driver, tho I also think they were available for sale somewhere. Also IAC I ultimately solved the problem, tho again, I no longer recall exactly how.

    Umm....I wonder, suppose you contacted some of the companies that sell this unit under their own name and inquired about buying or d/l-ing the drivers?
  8. I've sent e-mails to sony, NEC, and Optair, but have not received a response. Optair looks like it has minimal (if any) customer support, since it is mostly OEM.

    I guess I would have thought that XP, being older, paired with an older DVD-RW would have the drivers.

    As to the sound issue, I have no hardware conflicts coming up, and my overall sound works fine. I'm able to play a computer game just fine in which the game accesses the CD for sound... but again, this is with a CD, not a DVD.

    I'm really at a loss here. I've done a ton of searching for drivers and found none, other than a firmware update. I HAVE found references that say that the drivers should be standard for XP.

    Any help you or others could give would be great!!! Thanks!
  9. I have the same trouble which brought me here.
    I actually have a 7190.
    It has worked like a dream until now
    Dont stop reading yet
    I bought it needing a dvd writer and have I burned several (flawless)
    I put it to a older system w/XP2 and it setup fine with no drivers required.
    I used windows for cd-w and dvd fab for burning dvd's and everthing was great.
    I then foolishly put Nero 7 on it, then decided I didnt like it and uninstalled it.
    Then the trouble started. I couldnt write a data cd so I forumed around and got no answer, So then I deleted the drive and reinstalled.
    After that I then had the ability to write the cd I needed, but then a day or two later I was wanting to test a DVD before burning it. No codec.
    Ok I wasnt surprised by that so I uninstalled the K-Lite codec pack and put it back in.
    I used it before and I know it worked fine.
    I checked Mpeg-2 during the reinstall
    So I am a bit in a quandry at this point.
    I know however it isn't firmware, software,hardware
    It would seem as though it is probably a simple system setting that we need to figure out.

    Ps I have not changed anythig except Nero, the reinstall of the drive and the reinstall of K-Lite
  10. The best advice I can offer is, "experiment, and be persistent in experimenting. Of course, you want to keep a record of what you do, and make sure you dont do anything irreversible.

    Why cant I use an apostrophe here? Apostrophe just does not come out on the screen, and this is the only forum where that happens!
  11. Ok I figured it out.
    At least my troubles.
    Delete any codec packs (Aftermarket) that are installed.
    Goto device manager and uninstall the drive and reboot.
    Windows will automaticly reinstall the drive at boot.
    goto my computer and select the drive and properties. Under recording be sure the check box for writing is checked.
    Install the K-Lite codec pack. Just install it as is ok ok ok ok
    Movies will run afterwards.
Ask a new question

Read More

DVD Writers Decoder DVD Players Windows XP Storage