Sign in with
Sign up | Sign in
Your question

New Hitachi drive not being seen in 'my computer'

Last response: in Storage
Share
August 3, 2007 8:49:35 PM

I have a gigabyte ds3 mobo with a western digital sata 2 drive in it. I just bought this new Hitachi Deskstar sata 2 drive but although windows says 'new harddrive detected' it wont appear in 'my computer'. I have come to realise that the hitachi drive may be in sata2 mode only, and that perhaps my original drive is actually not using sata 2 either and that is why it wont recognise the original drive. So in the bios i think its set to SATA/IDE mode rather than ACHI. I get a blue screen if i turn achi mode on as it has to be installed with a fresh copy of xp. So, if it is set to IDE mode, does that mean SATA 2 isnt happening and perhaps thats why the new hitachi drive isnt being seen. Id rather not reinstall windows to get it to work. any ideas?

More about : hitachi drive computer

a b G Storage
August 3, 2007 9:09:00 PM

Go into disk management and set the drive up.
a b G Storage
August 3, 2007 9:33:44 PM

BadDad is correct, you need to setup the drive (partition, format, etc.) in order to see it in 'My Computer'.

Right-Click on 'My Computer' and select 'Manage'

Also, you don't have to reinstall Windows to switch to AHCI mode. The trick is to istall the AHCI driver while still in Windows. If you just change it to AHCI in the BIOS and try to boot, you'll blue screen because Windows doesn't have the driver installed and therefore can't use the boot drive.
Related resources
August 3, 2007 11:03:39 PM

thanks i hope this works. How stupid i feel, wasted about 6 hours trying to get this to work and the answer was so simple. idiot. anyway, thanks for the help. How do i activate the ahci driver whilst in windows? or should i just stick to the non ahci mode?
a b G Storage
August 3, 2007 11:37:27 PM

Starmonger said:
thanks i hope this works. How stupid i feel, wasted about 6 hours trying to get this to work and the answer was so simple. idiot. anyway, thanks for the help. How do i activate the ahci driver whilst in windows? or should i just stick to the non ahci mode?


I have a P5B-Dlx WiFi, but the procedure should be the same for switching from IDE to AHCI. There's actually two ways to do it. This assumes you are using the ICH8R controller.

#1 The first method requires you to have the AHCI driver handy. If you're running WinXP, your best bet is to get your motherboard CD. Find the folder on the CD where the AHCI drivers are located (iaahci.inf). Go to device manager, expand IDE ATA controllers and right click on the Intel IDE controller that your HDD is connected to (I don't recall what it's called exactly).

Select update drivers -> advanced -> don't search I will choose … -> have disk -> and browse to the above mentioned folder with AHCI drivers (select iaahci.inf). From the list select the Intel ICH8R driver.

After the update windows will suggest to restart your computer. Do so, and when booting go to the bios and enable AHCI mode; save setting and load windows.

Windows will now find new hardware and install it. After this is done just install the latest intel matrix storage manager and that's it.


-OR-

#2 With the computer off, simply connect your hard drive to a different SATA controller on the motherboard such as JMicron, Gigabyte, whatever... and boot up with that controller on IDE mode, but change your old controller to AHCI in the BIOS. Since you are using IDE mode on the current controller, the system will boot up and windows will detect the 'new' AHCI controller. Install the AHCI drivers and shutdown. Now, reconnect your hard drive to the original controller which is now set to AHCI. You should be able to boot into windows on the AHCI controller now.

The obvious advantage of the first method is that you don't have to break open the case and pull cables, but the second method is more fool-proof and easier to follow.

Hope this helps.

!