Sign in with
Sign up | Sign in
Your question

resource conflice (Code 12) on IDE DVD/CD ROM

Last response: in Storage
Share
August 5, 2007 5:39:00 AM

So i built this computer about 2 months ago and i realized that my DVD drive is no longer recognized by XP. it shows up in the BIOS but not XP. (Pioneer DVD-R200) When i go to device manager it give me a code 12

This device cannot find enough free resources that it can use. (Code 12)

If you want to use this device, you will need to disable one of the other devices on this system.

Click Troubleshoot to start the troubleshooter for this device.


The resource conflict is with the other primary slot (the secondary slots conflict with each other as well)
which is weird because i have only one drive connected to primary IDE (i then switched to secondary but still no luck)

Ive gone through troubleshooter but as i expected - no help. ive unstilled the drives and xp reinstalls them.

Ive tried updating drivers - but this one has none - i even checked the website.

Ive tried rolling back drivers - there are none.

i cant change resources because this isnt a plug and play apparently.

it was working at one point because i watched several movies and installed stuff about a month ago. i havent used it since then so i have no idea when it stopped.

i also tried uninstalling Roxio and its DLA stuff - still no luck.

Maybe this is relevent to somebody, but i have no floppy drive installed yet the A: drive (floppy) shows up under MyComputer. no idea why. maybe they are related?


ive searched all over the internet but can't seem to find a solution. maybe someone here could help me.

Specs:
P5NE SLI
E6600 @ 3.02
2GB G.Skill
Maxtor 160GB
Pioneer DVD-R200
BFG 7950GT 512mb

i appreciate all the replies in advance!

August 5, 2007 6:27:23 AM

Do you have one of those virtual CD/DVD programs like PowerISO or Virtual CD installed. If you create too many virtual drives then you can have resource issues. Resources can be IRQ or sector buffer related. Resources normally fit in the first 640K if I remember correctly and are therefore finite.

Since those virtual drives rely on a programmer not screwing up somewhere, if you have one installed then uninstall it and see what happens. Since you said it worked at one time then you are looking for something that changed recently.

One other possibility is that if you did not watch the movie till the end then the buffer may still exist so that you can resume where you left off. I could not use Roxio any more after I switched to Vista and the uninstall program can not remove all of it. I had to purge the startup service in the registry to stop conflicts but I refuse to reinstall Vista to get rid of all of it.
August 5, 2007 6:34:12 AM

I dont have any virtural CD/DVD programs other than Roxio like I said. but you did get me to think. I do have Hamachi installed (a virtual LAN program) so maybe that is doin it?

I'll uninstall that and see if it fixes it.
I know i didn't watch the movie until the end. but i do use the Drive to play SupCom and that woulda been the last time ive used it. How would i delete the buffer or whatever if that was the case?

thanks for the idea!
Related resources
August 5, 2007 6:41:22 AM

Ok so i uninstalled that but still no luck.

If it helps at all, the mobo has 2 IDE connectors however 4 IDE drives show up on Device manager. (2 Primary and 2 Secondary - both conflict with the other of its kind). However i do only have 1 DVD/CD Drive.

I did try to remove Roxio before this but it didnt work and since i have no drive i couldnt reinstall it - so i sys restored to the hour before :) 
i do know that i need it for something because the movies dont play on the computer unless Roxio is installed (even though i use WMP)
August 6, 2007 7:13:43 AM

any ideas anyone?
!