Sign in with
Sign up | Sign in
Your question

Man vs RAID 5 -- 4 x SpinPoint on XP PRO SP2

Last response: in Storage
Share
August 7, 2007 3:52:07 PM

I've been putting this off for a while, but finally decided that I wanted to put a four disk RAID 5 into my new build. The mobo is an ASUS P5N32-E SLI LGA 775 NVIDIA nForce 680i SLI ATX Intel Motherboard, with six SATA ports. I've got a 320Mb Samsung on SATA1 with the OS, which is XP Pro SP2. SATA2 is the DVD and I've set up SATA3-6 with 4 more 320MB Samsung drives. It is these four drives that I'd like to run in RAID 5, as a storage solution (not for the OS).

What I've done is identify the disks as part of the same RAID 5 array in the ASUS' RAID utility on first boot up. Machine boots up fine, but there is not one large, nifty RAID drive showing up in Windows Explorer. Interestingly enough, Windows did detect the drives and tried to go through the process of installing drivers for each of them. However, it failed at that task, as the machine wasn't where I could connect to the internet, and the drives (being OEM) didn't come with a driver disk. Odd, though, as I had no problem installing the first drive (exact same kind) that the OS is on, and didn't need to install any drivers.

Now, when I boot up, things are fine, but there is no sign of the RAID in Explorer. If I click the "Safely Remove Hardware" icon on the task bar, I can see all of the drives listed there as if they were an external drive. Also -- and I'm not sure if this is related, but think it is since it started at the same time as the RAID drive install -- now the machine will not actually turn off when performing a Shut Down. It will shut down the entire OS and get to the point where it normally would cut all power, but from there I need to shut it down with the power button.

So what am I doing wrong? Are there some drivers that I need to install via floppy to get XP to recognize the RAID array? I was under the impression that that was only required if you wanted to install the OS on a RAID, but now I'm beginning to have my doubts. Any help greatly appreciated...
August 13, 2007 3:50:19 AM

The fact that your physical disks are listed in the 'safe hardware removal' list is normal. This is because your Operating System, your controller and the disks themselves support the Hot Plug feature, allowing you to connect and disconnect a disk while the system is on - just like USB.

You should not use this feature though, as it would disconnect and thus degrade your RAID array. It's a bit sad Microsoft includes disks this way. Even DVD-drives in notebooks are sometimes in the list.

I'm not sure about your shutdown problem, not my expertise sorry. You might want to ask on the Windows forums instead.
August 13, 2007 6:07:47 PM

Thanks for the anwer on that. Believe it or not, my main hard drive with the OS installed is also listed in the "safe hardware removal" list. I'm almost perverse enough to try it just to see what would happen ... almost.

In the meantime, I've solved my RAID issues, and figure I might as well post here in case someone else is trying to figure it out. If you'll recall the starting premise, it was that I was going to run the OS on a single hard drive, then have four more drives in the system built into a RAID5 that I'd use for storage only. This was with the ASUS P5N32-E SLI Plus motherboard that has six SATA ports. I'd read all kinds of mythology and theory and downright bunk on how to set up a RAID on ASUS motherboards, but the majority of the solutions dealt with boards other than mine. The final answer, for once, turned out to be the easy one.

I started with the OS disk plugged in to the SATA 1 port and the DVD plugged into the SATA 2 port. The other four drives went into the last four available slots. On the first bootup, I hit the F10 button at the appropriate time, and went into the nVidia BIOS RAID management interface per the manual. This whole part of the process was well-defined in the manual. Once I had identified the disks I wanted included and chosen the type of RAID, I saved and exited. It was from here that it got confusing, and the manual didn't really make clear what you should do if you were installing a non-OS RAID.

It turns out that my system never had the nVidia storage manager installed on it. It had all of the other nVidia suite, but not that part. Once I finally figured that out, it was a simple drill to go to the nVidia website and download the latest nForce package for my OS. I then installed just the storage software. From there, straight to nForce disk management, and I was able to format the RAID 5 and now have a fully-functional array. So easy I wanted to bang my head on the desk. Incidentally, this also solved my shutdown woes, so that non-functional, half-finished array was the reason that the computer wouldn't shut down properly. Who woulda thunk it? So the moral of the story, kids, is to make sure you install all of the freakin' software for your motherboard, and you shouldn't have any problems.
Related resources
!