Sign in with
Sign up | Sign in
Your question
Closed

Eliminating static noise in headphones

Last response: in Components
Share
July 17, 2007 2:54:44 PM

Hi, I have recently started using headphones for gaming, but I have noticed that when there is no input, there is a static sound in my headset. I am using bose quietcomfort 2 hooked into my razer tarantula keyboard. Does anybody know how I can get rid of this sound? BTW, I'm unable to hook the headset directly into the computer because there is no attatchment for it on the front of the tower, and the back of the computer is too far away for me.

Oh, and if you know anything about these headphones, I DO have the input switch set HI.
July 17, 2007 3:56:58 PM

Do you have a sound card? If you do, then hooking your headphones up to your keyboard won't allow you to utilize it. Also, with all the data that flows through the USB the keyboard is hooked up to, using it for sound to your headphones may allow some interference to leak into the sound channels. And last but not least, they are noise cancelling headphones. Setting the input switch to high may turn up the noise cancelling abilities. That means in a quiet room, the noise cancelling may actually emit sound; responding to the lack of noise to cancel (i think that makes sense?) Try tuning the sound properties from your computer. Set speaker setup to headphones, and play with the sound mixer. Try not to allow any setting to "max out", keep the levels as close to equal as possible. This should also clear up some static.
July 17, 2007 4:25:29 PM

You could try running an extension cable to the back of your machine. I know I have a 10ft 3.5mm cable around here somewhere. I'm guessing you're getting interference from your keyboard's circuitry.

Try pulling your machine out and plugging into the back, though, just to see if the sound is clearer and static-free. If so, buy an extension cable.
Related resources
July 17, 2007 4:37:24 PM

You coudl buy one of those fancy Soundblaster cards that come with input/outputs on a 5 1/4 bay cover
July 17, 2007 7:09:00 PM

OMG I feel like an idiot, I plugged my headphones straight into the back, and my blacks r black again...or in this case my quiet is actually quiet :) 

I guess that keyboard was just causing interferance. Now my next problem is that I need to pick up an extension cord...Also, is there any cheap solution to adding a headphone jack to my comp, because right now, I can't switch back to my speakers w/o manually going behind my comp. On XP I can fix this with my RealTek (sp?) driver, which will allow me to put headphone in another jack. On Vista though, the driver interface changes...
July 17, 2007 11:48:37 PM

Not sure about vista, but i know with my X-Fi card you can set to auto detect headphones. The speakers will stay on, and you have to manually turn off your speakers when using headphones. It might depend on your audio chipset, but you can look for it. I'm sure its possible.
If you have an empty 3.5" bay on your pc, you can try this http://www.newegg.com/Product/Product.aspx?Item=N82E16813999356 It will use the internal sound hook ups for your headphones and add a mic input. The extra USB and firewire don't hurt either if you have the extra internal connectors.

@novathunder: I HATE the new forum. Especially the double-underlined green text WTF? I didn't create an ad link! And it messes me up when i skim pages.
!