Sign in with
Sign up | Sign in
Your question

Intel Pentium-D Dual Core 1.8Ghz

Last response: in CPUs
Share
July 20, 2007 1:56:55 PM

Alright guys I recently bought this new CPU; Intel Pentium-D Dual Core 1800MHz LGA775 1MB, my problem is when I 'installed' the CPU and hit the power switch there is no image showing on my screen - I tried to pull out my Drives in order to see if it was the PSU being too weak - Still no result .

I went from a Intel Celeron 3.2GHz CPU Socket775 .

Can anyone guide me here ?

Regards.
July 20, 2007 2:15:12 PM

Can your motherboard support the core microarchitecture? If your old cpu was a Celeron 350/351/352, it has FSB 533MHz so perhaps your mobo only supports up to that much. What you just got was an E2160 right? It has an 800Mhz FSB. Reply with your motherboard model.
Jo
July 20, 2007 2:17:42 PM

What is your motherboard? Chances are, if it's more than a year old, your motherboard will not support the new Pentium E2160 processor. Check your mobo manufacturer's website for CPU compatibility. Your power supply is not the problem, as the new CPU consumes the same or less power than the old Celeron D.
Related resources
July 20, 2007 2:28:42 PM

ASrock 775Dual-880Pro

The thing is we (my friend and I) tried for fun to switch my old CPU with his Pentium-D Dual Core 1.7GHz and it worked perfectly.
July 20, 2007 3:22:12 PM

Bump :<
July 20, 2007 3:35:56 PM

It appears that the PT880 Pro chipset in this mobo supports Core2 (http://en.wikipedia.org/wiki/Intel_Core_2), so this is not the problem. Does it start to boot and then disappear or nothing at all - fans spin, lights on but no manufacturer logo, no signal and no way to get into the bios?
Jo
July 20, 2007 3:55:45 PM

No, no way to get into the bios - Everything spins, lights on - Only the screen not showing the image it is just 'blinking' as if the computer wasn't turned on and the screen still was.
July 20, 2007 4:08:07 PM

Sounds more like you didn't attach the CPU power cable. It should be a four pin connector.
July 20, 2007 4:10:34 PM

I guess try resetting the cmos by momentarily changing the right jumper (see manual) or just pulling out the motherboard's battery for 30s. Perhaps the bios can't adjust to the new cpu but may when reset to factory settings.
Jo
July 20, 2007 4:18:27 PM

Jmecc - How do I pull out the modo battery ?
July 20, 2007 4:52:04 PM

Find the battery - looks like it's to the right of the 2nd & 3rd pci slots from the pics I see, and unclip it. The battery is held in by a clip you can push over (don't force on it) to pop the battery out. Remember which side of the battery faces up and put it back in the same way in a minute.
Jo

Edit: of course unplug the computer when you are doing this
July 20, 2007 10:27:08 PM

Im such a retard -.- . Thanks joe, now I gotta see what I can do next ^^
!