Sign in with
Sign up | Sign in
Your question

nVidia 680i LT + Hitachi Deskstar Drives + RAID = Trouble!

Last response: in Storage
Share
August 25, 2007 2:08:46 AM

Hello folks. I'm in a bit of some troubleshooting hell. This might be a lengthy post, but I always try to be as specific and as detailed as possible. I've been seeking help around the web, so if you can suggest other sites to post this on, I'd be appreciative as well.

THE RIG
EVGA 680i LT A1 Motherboard
Intel Core 2 Duo E6600 (2.4 Ghz)
Corsair XMS2 Memory (4x 1GB)
EVGA nVidia Gefroce 8800GTS (320MB)
1x Hitachi 7K500 (SATA II / 250GB / No RAID) on SATA Ports 0.0
2x Hitachi 7K250 (HDS722525VLSA80 / SATA I / 250GB / RAID1) on SATA Ports 2.0 & 2.1
Nothing is overclocked

THE HISTORY
I did a system overhaul from my old Gigabyte Pentium 4 board to this Core 2 Duo board. Basically, it's a whole new system minus the drives. During the board swap, because of the different RAID controllers, I backed up the data on the RAID1 volume, and then copied it back on the EVGA board. I of course had to delete old arrays and create a new RAID1 volume, and format it. Then, copied everything back. The SATA II drive is the Windows Vista drive. The RAID1 volume is just storage and such. I did a clean install of Vista after the board swap. Yay. System is done. No data lost.

<< FAST FORWARD TWO WEEKS >>

THE PROBLEM
I'm doing some normal computing, and I installed some simple Windows Vista updates (nothing relating to drivers) and it asked me to reboot, so I did. Upon waiting for the system to boot, it just froze after the Windows boot screen on a totally black screen. Then, I rebooted, this time noticing that MediaShield was telling me the RAID1 volume was "Degraded". It also showed two RAID1 volumes instead of just one. I suppose one for each drive. Still, the system wouldn't boot.

So, I unhooked the RAID1 drives and the system booted just fine. Then, I attached each of those drives to my laptop with an eSATA card, and both drives had all data there. I randomly checked several files around the drives and couldn't find any errors. So, I took that opportunity to backup the data.

Now, I put the drives back on the EVGA board, went into the BIOS MediaShield utility, deleted the two RAID1 volumes, and recreated a single RAID1 volume. Rebooted. This time, Windows started fine. I used Acronis Disk Director to format the RAID1 volume. As soon as the format completes, I get flooded with "RAID Access Failure" balloon popups in the system tray from the nVidia drivers. Opening Explorer, I can't open the volume.

So that's the problem.

TROUBLESHOOTING
  • I've tried deleting and recreating the volumes several times. I've tried formatting with Acronis Disk Directory and Windows Vista. Same results.
  • If I disable the RAID functions in the BIOS, Vista will boot, and sometimes I can format the drives and access them individually, and sometimes I can't. Whichever the case, both drives always behave the same.
  • I've tried different (new) SATA cables.
  • I've tried different power supplies on the drives.
  • I've tried using different combinations of SATA ports to make the RAID1 volume.
  • The drives ALWAYS report degraded immediately after formatting, but never before.
  • I had two 80GB Hitachi Deskstars (HDS722580VLSA80) sitting around so I tried those, and both of those do the EXACT same thing.
  • I also did a clean install of Vista just to be sure. No changes after.
  • I'm using the nForce 15.01 package, which is the latest.
  • I bought two brand new Hitachi Deskstar T7K500 drives, which are SATA II. Those drives have no problem whatsoever.. so far.
  • I just RMA'd my motherboard to make sure it wasn't a bad board. The replacement does the same thing.
  • I've ran Hitachi Drive Fitness Tool (always Advanced Tests) on all problematic 250GB and 80GB drives. No error is ever found. Since you can't test them in RAID, I have to disable RAID first. The two 250GB drives both complete the test in exactly 1 hour 28 minutes.
  • I've also done low-level formats using the DFT on all drives.
  • These drives pre-date SATA II, so it's not like I can try a different mode or anything.
  • If it is a compatibility issue, why did it work when the board was new for two weeks?

    What should I do next? I'll be sending this post to Hitachi, but they won't RMA a drive unless DFT returns an error code. I already e-mailed them, and they have no records of compatibility issues with the 680i. I've read on other forums about tons of problems with nForce4 chipset boards and Hitachi drives. Personally, I've used Hitachi drives since before they were Hitachi (IBM), and I've NEVER had one go bad, which is why I have so many of them. I also use Hitachi Travelstars exclusively in my laptops. I'm just really stuck here. Ahh! Help!

    Thanks in advance.
    a b G Storage
    August 25, 2007 3:03:00 AM

    Well I've had many a DeathStar go bad on me but I don't think thats your problem. It seems to me I remember something about vista not handling raid well.
    August 25, 2007 3:19:24 AM

    Well, I've used these drives in Vista for over a year in RAID with the Gigabyte board. Worked for two weeks with this EVGA board. Even then, the BIOS itself seems to dislike it.
    !