Sign in with
Sign up | Sign in
Your question

Intermittent Detection Prob w/ Lacie USB2 500 GB External

Last response: in Storage
Share
August 25, 2007 6:14:34 PM

Hi, I'm having trouble with my newly bought Lacie USB2 500 GB External HD.

My computer is able to detect it but the drive will intermittently disappear and then reappear. I even hear the disconnect/reconnect plug & play device sound when this happens. I can watch in windows explorer as the drives appear and disappear one by one.

If I try to write something to the drive it will seem to be fine until the drive disappears (obviously) and I get a delayed write failure message.

Sometimes Windows will tell me it isn't able to properly install the hardware, and sometimes it says it's properly installed it, but then I get the weird intermittent detection. I've tried updating my USB2 driver already and all my firmware is up to date with the latest versions.

Oddly enough, I've connected the drive to my sister's laptop and even taken it back to the store where they connected it to a desktop and on both of those computers the drive was fully recognized and had no connection issues. It appears the problem might be some sort of incompatibility with my system specifically - Infonec won't take it back because the package is opened and b/c the problem seems to only occur on my desktop. Lacie won't take it back because there's nothing wrong with the drive itself, since it works on other computers... so I now have a $137 paperweight, can anyone help me?

I'm running Windows XP SP2 on an Asus P4B533-E, 2.0 GHz, 2 disk RAID 0 (these are both internal, not the external and they run fine).

Thanks in advance!
August 25, 2007 6:30:07 PM

The P4B533-E is a pretty old motherboard (i845 chipset, ICH4/82801DB south bridge, first USB 2.0 implementation by Intel).

I would try to solve the problem by getting a good USB 2.0 PCI card and using that instead of the onboard USB. I bet the disconnect/reconnect problems go away.

Try the Koutech PCI to USB card. NEC chip (known to do USB 2.0 correctly), $15 so hardly anything to lose there, and no drivers required under XP or Vista.
August 27, 2007 6:34:58 PM

Thanks SomeJoe7777, your suggested fix worked - I bought a Syba PCI to USB card with an NEC chip (4+1 ports) and everything is perfect!

I guess the issue was that the computer detected the USB 2 capability but that the onboard controller was not quite able to do its advertised job. Further evidence that this was the case: I connected the drive to an ancient (USB1.1 capable only) P3 600 MHz and the drive worked fine there too, just slower.

Thanks again!
Related resources
August 28, 2007 1:00:16 AM

Glad it worked. Ya, Intel will never admit it, but they make mistakes too. ;) 
June 6, 2009 4:51:43 AM

So, I'm having the exact same problem as vorpalbunny, only I'm using my drive on an 2008 Intel Macbook. I've heard of other users of this drive (Macintosh and PC) having the same problems... Could an old usb chipset really be my problem on a machine this current? I suspect the drive is at fault but after hearing vorpalbunny's testimonial I am only more confused.
!