New HTPC build wont post!

Clever people of TH I need your help :)

My brothers new build wont post. Power, lights, fans but no display or post beep codes. Im not even sure the case has an internal fan since theres no speaker cable, only the front panel hd/legacy audio connecter.

Ive tried removing and reseating all components but no joy. Is this a possible case of fried mobo syndrome? :(

e4300
Gigabyte G33-DS2R uATX
2gb OCZ pc6400
Sapphire 2400pro
Antec Fusion case

Cant think of anything else relevant atm...

Help? :(

Thank you!
9 answers Last reply
More about htpc build wont post
  1. Do you have another GPU you can try?
  2. Aye but only my own. I wanted to leave opening my case until the last option but meh I may aswell.

    Wish me luck.
  3. Is the MB secured to the case well? Make sure there is no shorts.
  4. where's the sticky for no post
    http://www.tomshardware.com/forum/97744-30-motherboards

    Quote:
    A. Most likely cause of this situation is the motherboard being grounded by a misplaced mounting post. Check to make sure all the post line up with all the holes in the motherboard, and remove any posts that don't.


    sometimes it's that pesky screw that you thought you picked up {but didn't}

    sometimes it's holes that are only for plastic not metal {no shinny rings, upgrading OR part replacements}
  5. Still no joy.
    Took my computer apart...
    - my x1950 in his mobo, nothing
    - his 2400pro in my mobo, works fine

    We even hovered my computer over his to be able to connect my internal speaker to his motherboard. Still no beep codes with any component configuration.

    Good idea Coldmast, i know its not a screw but it could be the standoffs. Unfortunately when i went to put my computer back together again I came back to find he had dismantled the HTPC right down to the HSF.

    So... to save the hassle of buying more paste (closest computer shop is 50 miles away), if I were to fire up the motherboard with no heatsink... and free of the standoffs (on a piece of cardboard I believe ive seen people testing them on?), it might POST even if just for a second before the temp sensor shuts it down?

    Much appreciated :)
  6. "fire up" being the answer

    you should at least throw the HSF on top before you render it useless.
  7. This may be regarded as foolish, but make sure you have both power connectors connected to the motherboard (both the 4 pin and the 20 pin power connectors). I once left the 4 pin unplugged and was getting a similar problem. Good luck!
  8. Oh christ... I think that was the problem... What an absolutely elementary mistake... Im really dissapointed with myself for not spotting that... :(

    I blame the Antec Fusions seperate chamber for the psu for me not thinking about the second power connector. Poor excuse I know. Fingers crossed it works when i build it back up tonight.
  9. [:coldmast]

    :pt1cable:
    :non:
    :lol: :lol: :lol: :lol: :lol:
    those included motherboard books are difficult stuff {sarcasm}

    but hey it happens to us all once and a while
Ask a new question

Read More

Homebuilt Systems