Sign in with
Sign up | Sign in
Your question

Is this forum up to the task of solving my problem?

Tags:
Last response: in CPUs
Share
July 25, 2007 2:27:57 PM

Ok I've posted this once or twice before, but arrived at no solution. Before I start, here is my system:

Pentium D805 2.66GHz dual core processor
ASRock Dual 880 Pro motherboard
2 x 1GB Corsair Twin-X DDR2-667
e-VGA 7900GS
Maxtor 60GB HDD

When I first put my system together, like last year some time, it was working fine. I ran CPU-Z and it would show numbers for both cores (as it should) and in task manager I would see two seperate graphs for performance (as I should).

But then one day, one of the cores stopped working, or so it seemed. I checked the task manager and there was only one graph. I tried to select one graph per CPU or whatever but it made no difference. I ran CPU-Z and same thing. The drop down menu to select which core to dispaly was grayed out and it would only show one core. Then I went into device manager and under CPU it, in fact, shows 2 different CPUs.

It seems to me that windows is recognizing the two cores but for some reason is unable to utilize them, but I'm no expert. I've since put a fresh copy of windows on the hard drive but nothing changed. I used to think that maybe one core was just faulty on the CPU but people said it doesn't work like that. So now I'm here :hello: 
July 25, 2007 2:49:15 PM

Try running Linux on your PC (you can get a bootable Linux CD of Ubuntu for example).

Then if Linux doesn't recognise the two cores you know it's a hardware issue. Then it is either a screwed BIOS, mobo or chip.

From what I have heard the mobo you are using is a pretty flaky one so maybe that's the problem? You could also try dropping in an alternative chip if you can get your hands on one to prove mobo vs chip.
July 25, 2007 3:05:00 PM

Have you cleared your CMOS and updated the BIOS to the latest revision? I'd do that first before anything else. Also, noticed you're running Corsair ram. You might want to run MemTest on your RAM to make certain you don't have a bad stick. I had a bad stick of Corsair C4 ram, and it caused errors in PCI allocation and how my RAID chip functioned. You should get zero errors from MemTest at standard clock stettings.
Related resources
July 25, 2007 3:15:50 PM

Thanks for the replies guys. I'll try out the solutions suggested when I get home today or tomorrow because I might not have time today. I think I have a SUSE Linux CD laying around somewhere that I could try. After that I'll run the MemTest and work on the BIOS. These solutions were not previously suggested so hopefully I find the problem.
July 26, 2007 6:34:40 PM

np - gl!
July 27, 2007 2:45:50 AM

its possible that both cores work and since all the programs you note utilize the same method to track the cores are unable to track the second core.

if the temp is the same the 2nd core still works
if your temp has dropped slightly the 2nd core is not working

temperature is an 100% infallible predictor or whether both cores work

July 31, 2007 1:58:59 AM

Alright so I got a SUSE live CD of linux, it was v9.2. But in the system info it didn't say anything about how many cores my processor had. It recognized the name and everything but nothing about single or dual core. Is there another version I should try?

Also, I ran memtest on 1700 MB out of the 2048 I have for about 260% (so I guess that's like 2 and a half times over) and it had zero errors.

The only thing left to try is taking out the CMOS battery. I'll try that next when I have time.

EDIT: I just noticed that CPU-Z is recognizing all of the L2 cache (2 x 1024kb) but in SUSE live it only reported 1024. So does that point to hardware issue? If anyone can recommend another linux version that has good system info reporting that would be good. TIA.
July 31, 2007 3:26:11 AM

i still think its a microsoft error - check the regirstry for the cpu
July 31, 2007 1:52:48 PM

dragonsprayer said:
i still think its a microsoft error - check the regirstry for the cpu


How do I do that?
!