Sign in with
Sign up | Sign in
Your question

Should I disable Speedstep?

Last response: in CPUs
Share
July 26, 2007 4:50:52 AM

I haven en e6600, and was wondering if Speedstep is required or boosts performance. Because if it doesn't, should I disable it? Thanks

More about : disable speedstep

July 26, 2007 4:51:46 AM

Do you plan to oc?
Related resources
July 26, 2007 5:43:38 AM

Leave it on, if you're not overclocking.

All it does is put the CPU in a "sleep" state when idle. That's about it. It won't harm anything, and might even prolong the life of the CPU. Maybe.
July 26, 2007 5:54:16 AM

NMDante is right if your not going to OC then leave it on.
July 26, 2007 6:10:39 AM

NMDante said:
Leave it on, if you're not overclocking.

All it does is put the CPU in a "sleep" state when idle. That's about it. It won't harm anything, and might even prolong the life of the CPU. Maybe.



Yes i agree ;) 

And you can always disable it later(if you want).
July 26, 2007 7:09:30 AM

Oh ok. On another note, is having a core 2 duo going to make my pc boot faster? It takes like 1:20 seconds before I can click things and all apps are loaded. Is this xp or my processor not booting fast? I was just wondering if this is normal.
July 26, 2007 7:40:53 AM

Eucharistadorer said:
Oh ok. On another note, is having a core 2 duo going to make my pc boot faster? It takes like 1:20 seconds before I can click things and all apps are loaded. Is this xp or my processor not booting fast? I was just wondering if this is normal.


Its all about how fast the hard drive is. I went from your standard sata Maxtor 80GB 7,200RPM HDD from my Dell computer to a Raptor 150GB 10,000 RPM drive. Windows loads so fast now that I never see that welcome blue screen just before you get to desktop. Raptors have gone down in price since I got mine, for a 150GB HDD its about $249.99 at Western Digital's website. Less than 20 seconds to reach my desktop.
July 26, 2007 8:00:38 AM

Not just the hard drive it IS majorly about the CPU aswell.


RAM should play a key part when you get to the desktop too.
July 26, 2007 3:58:41 PM

Well I have 3 gigs of ddr2 400mhz, a 7200 rpm Western Digital Caviar SE, and an Intel Core 2 duo e6600. Is there something wrong with my cpu, or this setup, that is making my boot time 1 minute 20 seconds? Shouldn't the core 2 duo be faster than that? I keep thinking Newegg sent me a faulty cpu....


Edit: I have three startup items: nod32, spysweeper and my motherboard's audio. And I also have services to the bare minimum needed to run windows, my wireless connection, my printer and my usb and external hdd devices. What can I do to speed it up?
July 26, 2007 6:42:03 PM

Well Spysweeper does take a while to load. Have you disabled the pre-fetch? Clear out your pre-fetch folder that may help but if you are taking 1.3 minutes to boot and you have 3 gigs of ram then you certainly have some issue somewhere.
July 26, 2007 6:56:12 PM

It was 1 minute and 20 seconds. Could it be my ram speed?

How do I disable my pre fetch folder, that's not going to affect Windows is it? Probably a stupid question....
July 26, 2007 8:29:00 PM

are you counting that 1.3m from the time the computer turns on? If so, maybe check the boot order and try putting the HDD first.
July 26, 2007 8:53:57 PM

Ya, it's from the time I press the power button. Should run Windows Memory Diagnostic to see if something's wrong with my ram? And, is it my ram speed or not?

I already have the pc booting from the hdd first.
July 27, 2007 2:07:22 AM

Also in my bios theres an option called "Quick Boot" that boot into Windows faster, so It might be just a simple setting. It should not take 1:20 seconds to get to desktop, something else is causing the slow boot of Windows. You might have a virus, something not set right. Look in you bios for quick boot. My old PC that had a P4 3.0GHz never took more than 40 seconds to load XP.
July 27, 2007 3:25:32 AM

That's what I'm trying to figure out. But in my bios, there is no "quick boot" feature. Could I maybe have gotten a faulty mobo or cpu?
July 27, 2007 4:04:13 AM

The chance of you having a fault part and it showing up in load time is very very small. If anything is faulty it will show up in errors and system crashs and other things, not really load times.

The first most obvious step is to make sure you have your hard drive defragmented. If it is badly fragemented that could increase load times considerably. It also helps if your drive has a decent amount free, if you've got your HD loaded down to 100MB free or something it could have problems too.

One other thing is to go into your BIOS and define your drives manually rather then having the system do a search for them every time the system boots. If you have 2 IDE channels and only 1 drive on them, disable the other channel, and turn off the search for the IDE/SATA channels that have no hardware hooked to them. Generally to set a device manually instead of auto-search you have the BIOS search for it once then switch it to manual and it will remember what it found before. This took at least 5-10 seconds off my boot time.
July 27, 2007 4:51:52 AM

So the processors doing what it's supposed to do? That's good to know.

Ya, I just defragged yesterday, and I have a 250gb drive with 150gb free.

So, if I have multiple IDE channels, just disable all of them except for the one the drive is on? I'll try that and let you know what happens.

Will disabling the mobo splash screen shave off a few seconds?
July 27, 2007 5:22:53 AM

Is your 3 gigs of RAM in dual channel???? It could make the difference.
July 27, 2007 6:29:33 PM

open system configuration utility from: start - help and support - tools -system cinfiguration utility. Or just go to start - run, and type "msconfig" (without quotes)

click the "selective Startup" button

On the "BOOT.INI" tab make sure the "timeout" box is set to 3 sec and check the /NOGUIBOOT checkbox to loose the XP splash screen.

goto the "services" tab and check the "hide all MS services" box.

Now uncheck (will no longer load at startup) anything that is not necessary.

goto the "startup tab" loose anything that you dont NEED at startup.

If you have 50 startup tab items and you dont know what they are for then just try disabling a bunch of them and see if yu have any issues. IF not then turn off some more. If so, then turn some back on. But figure out what you need and dont need at start and turn off ALL that are not necessary.

I have my NOD32 and Zone Alarm start at startup and thats it. And they both are fairly resource hungry. I also take easliy over a minute to get to a usable desktop. If I shut them both off my desktop hits easily 30 sec faster. If you want to see how much difference in startup times your NOD and things make try unchecking EVERYTHING from the startup and services tab(leave the MS services) and see how long it takes to boot with NOTHING loading at startup.

Its all the XP SP2 updates that are bogging down your system. When you first load XP (without all the updates) I hit the desktop like 30sec. by the time your dont updating the 500 security patches and all that , the load time triples. A fast CPU speed up start time. A really fast HD will definately helps even more.
July 28, 2007 4:41:11 AM

But I have a fast cpu, an e6600, shouldn't that be making things startup fast?

As for Windows services- I have only the bare minimum to run things like internet connections, Windows itself and my usb devices. For startup programs, all I have starting are Spysweeper, nod32 and a program to make my onboard audio work. So I really don't have a lot starting with xp. Someone told me that Nod32 is the problem, that it was reviewed to take 60 seconds to start by cnet. So I don't know...
August 19, 2009 9:23:20 PM

Eucharistadorer said:
So the processors doing what it's supposed to do? That's good to know.

Ya, I just defragged yesterday, and I have a 250gb drive with 150gb free.

So, if I have multiple IDE channels, just disable all of them except for the one the drive is on? I'll try that and let you know what happens.

Will disabling the mobo splash screen shave off a few seconds?


Just take an A+ computer course. It's up to you whether you get the cert. or not but it sure helped me improve my computer skills. It's usually fairly cheap, and something like 40 hours to complete. You won't regret it.
January 9, 2013 5:34:13 AM

Just disable speedstep in setup.
I had similar problem when task manager showed 100% CPU load while several noto critical for CPU tasks were executing.
I turned off speedstep in BIOS and now I don't have such a problem.
It was true for Win XP, Windows Server 2003 and Windows 7.
May be with newer implementation of CPU it works well,
but I have old DELL E1705 Laptop with T2400 Processor and it goes much better when speedstep if OFF
!